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Important user information 
Read this document and the documents listed in the additional resources section about installation, configuration, and operation of this 
equipment before you install, configure, operate, or maintain this product. Users are required to familiarize themselves with installation and 
wiring instructions in addition to requirements of all applicable codes, laws, and standards. 

Activities including installation, adjustments, putting into service, use, assembly, disassembly, and maintenance are required to be carried 
out by suitably trained personnel in accordance with applicable code of practice. If this equipment is used in a manner not specified by the 
manufacturer, the protection provided by the equipment may be impaired. 

In no event will Rockwell Automation, Inc. be responsible or liable for indirect or consequential damages resulting from the use or 
application of this equipment. 

The examples and diagrams in this manual are included solely for illustrative purposes. Because of the many variables and requirements 
associated with any particular installation, Rockwell Automation, Inc. cannot assume responsibility or liability for actual use based on the 
examples and diagrams. 

No patent liability is assumed by Rockwell Automation, Inc. with respect to use of information, circuits, equipment, or software described 
in this manual. 

Reproduction of the contents of this manual, in whole or in part, without written permission of Rockwell Automation, Inc., is prohibited. 

Throughout this manual, when necessary, we use notes to make you aware of safety considerations. 

 
WARNING: Identifies information about practices or circumstances that can cause an explosion in a hazardous environment, which may lead to 
personal injury or death, property damage, or economic loss. 

 
ATTENTION: Identifies information about practices or circumstances that can lead to personal injury or death, property damage, or economic 
loss. Attentions help you identify a hazard, avoid a hazard, and recognize the consequence 

Important: Identifies information that is critical for successful application and understanding of the product. 

Labels may also be on or inside the equipment to provide specific precautions. 

 
SHOCK HAZARD: Labels may be on or inside the equipment, for example, a drive or motor, to alert people that dangerous voltage may be 
present. 

 
BURN HAZARD: Labels may be on or inside the equipment, for example, a drive or motor, to alert people that surfaces may reach dangerous 
temperatures. 

 
ARC FLASH HAZARD: Labels may be on or inside the equipment, for example, a motor control center, to alert people to potential Arc Flash. Arc 
Flash will cause severe injury or death. Wear proper Personal Protective Equipment (PPE). Follow ALL Regulatory requirements for safe work 
practices and for Personal Protective Equipment (PPE). 

Allen-Bradley, Rockwell Software, Rockwell Automation, and TechConnect are trademarks of Rockwell Automation, Inc. 

Trademarks not belonging to Rockwell Automation are property of their respective companies. 
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Preface 

This getting results guide provides you with information on how to install 
and navigate the RSNetWorx™ for ControlNet™ software. It explains how 
to effectively use the RSNetWorx for ControlNet software and how to access 
and navigate the online help. 

We assume that you are familiar with: 

 Microsoft® Windows® operating systems 

 RSLinx® Classic™ communications software 

The Getting Results with RSNetWorx for ControlNet guide can be considered 
the entry point into Rockwell Software’s documentation set for this product. 
Other components of the documentation set include online help, Online 
Books, and electronic release notes. 

The documentation set contains pertinent, easily accessible product 
information. This set ships with the software product, and is designed to free 
you from tedious paper shuffling and reduce information overload. 

The online help includes all overview, procedural, screen, and reference 
information for the product. The help contains these basic components: 
overview topics, quick start topics, step-by-step procedures, troubleshooting 
topics, and screen element descriptions (for example, text boxes, drop-down 
lists, and option buttons). All of the help is context-sensitive with the 
application and provides you with immediate access to application tasks and 
screen element descriptions. Refer to the "Finding the information you need" 
chapter in this guide for a more detailed description of the online help. 

Within RSNetWorx for ControlNet, we provide a Product Manuals feature 
that allows you to immediately access and search your product 
documentation from the Help menu. This feature includes the Getting Results 
with RSNetWorx for ControlNet guide, as well as several hardware product 
reference guides, in an electronic book format. As a part of the product 
installation, you have the option of installing these electronic books to your 
local hard drive during installation, or access them directly from the 
installation files. 

Tip: The product manuals included with RSNetWorx for ControlNet are in portable 
document format (PDF), and can be viewed using Adobe® Acrobat® Reader. 

 

If you cannot find the answer to your question in the documentation or on 
the Internet, contact Rockwell Automation Technical Support, using any of 
these methods: 

 Telephone: 1-440-646-3434 

Purpose of this document 

Intended audience 

How does this guide fit in 
with other Rockwell 
Software product 
documentation? 

Online help 

Product manuals 

Contact Rockwell 
Automation Technical 
Support 
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 Online: 
https://www.rockwellautomation.com/global/support/overview.page  

Support staff are available Monday to Friday from 8:00 a.m. to 5:00 p.m. 
local time (North America only), except on statutory holidays. 

Copyright notice 

Copyright © 2018 Rockwell Automation Technologies, Inc. All Rights 
Reserved. Printed in USA. 

This document and any accompanying Rockwell Software products are 
copyrighted by Rockwell Automation Technologies, Inc. Any reproduction 
and/or distribution without prior written consent from Rockwell Automation 
Technologies, Inc. is strictly prohibited. Please refer to the license agreement 
for details. 

End User License Agreement (EULA) 

You can view the Rockwell Automation End-User License Agreement 
("EULA") by opening the Rockwell_EULA_02102016_Final.pdf file located 
in your product's install folder on your hard drive. 

Open Source Licenses 

The software included in this product contains copyrighted software that is 
licensed under one or more open source licenses. Copies of those licenses are 
included with the software. Corresponding Source code for open source 
packages included in this product are located at their respective web site(s). 

Alternately, obtain complete Corresponding Source code by contacting 
Rockwell Automation via the Contact form on the Rockwell Automation 
website: 
http://www.rockwellautomation.com/global/about-us/contact/contact.page    
Please include "Open Source" as part of the request text. 

A full list of all open source software used in this product and their 
corresponding licenses can be found in the OPENSOURCE folder  included 
with this product's Release Notes respectively. The default installed location 
of these licenses is: 

 For RSNetWorx for ControlNet, C:\Program Files (x86)\Common 
Files\Rockwell\Help\RSNetWorx for ControlNet Release 
Notes\OPENSOURCE\index.htm. 

 For RSNetWorx for DeviceNet, C:\Program Files (x86)\Common 
Files\Rockwell\Help\RSNetWorx for DeviceNet Release 
Notes\OPENSOURCE\index.htm. 

 For RSNetWorx for EtherNet/IP, C:\Program Files (x86)\Common 
Files\Rockwell\Help\RSNetWorx for EtherNetIP Release 
Notes\OPENSOURCE\index.htm. 

Legal Notices 

https://www.rockwellautomation.com/global/support/overview.page
http://www.rockwellautomation.com/global/about-us/contact/contact.page
/usmkesrv7265/Publishing/PROD/IndividualPublishing/ZhaoRi/Word%20(Manuals)/Getting%20Results%20with%20RSNetWorx%20for%20ControlNet/OPENSOURCE/index.htm
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Trademark Notices 

Advanced Interface Series, AdvanceDDE, Allen-Bradley, Arena, 
ControlLogix, ControlView, Data Highway Plus, Datapac, DH+, Emonitor, 
Emonitor Odyssey, Enlab, Enlube, Enpac, Enshare, Entrx, Enwatch, 
eProcedure, FactoryTalk, FactoryTalk Activation, FactoryTalk Activation 
Manager, FactoryTalk Administration Console, FactoryTalk Alarms and 
Events, FactoryTalk AssetCentre, FactoryTalk Audit, FactoryTalk 
Automation Platform, FactoryTalk Batch, FactoryTalk Diagnostics, 
FactoryTalk Directory, FactoryTalk Gateway, FactoryTalk Historian Classic, 
FactoryTalk Historian for Batch, FactoryTalk Live Data, FactoryTalk 
Metrics, FactoryTalk Portal, FactoryTalk ProductionCentre, FactoryTalk 
Scheduler, FactoryTalk Security, FactoryTalk Services Platform, 
FactoryTalk Transaction Manager, FactoryTalk View, FactoryTalk View 
Machine Edition, FactoryTalk View SE, FactoryTalk View Studio, 
GuardLogix, GuardPLC™, MicroLogix, MobileView, MotorMonitor, ODS, 
PanelBuilder, PanelView, PhaseManager, PlantLink, PLC-2, PLC-3, PLC-5, 
PowerMonitor, ProcessLogix, Propack Data, Rockwell Automation, 
Rockwell Software, RSAssetSecurity, RSBizWare, BatchCampaign, 
BatchHistorian, Historian, MaterialTrack, PlantMetrics, Scheduler, 
RSEnergyMetrix, RSLadder, RSLinx, RSLinx Classic, RSLinx Enterprise, 
RSLogix, RSLogix 5, RSLogix 500, RSLogix 5000, RSLogix Emulate, 
RSLoop Optimizer, RSMACC, RSNetWorx, RSNetWorx for ControlNet, 
RSNetWorx for DeviceNet, RSNetWorx for EtherNet/IP, RSOPC Gateway, 
RSPower, RSSql, RSTrend, RSTune, RSView, RSView32, SLC, SLC 500, 
SoftLogix, Studio 5000 Logix Designer, VersaView, WINtelligent, and XM 
are trademarks of Rockwell Automation, Inc. 

Any Rockwell Automation logo, software or hardware product not 
mentioned herein is also a trademark, registered or otherwise, of Rockwell 
Automation, Inc. 

Other Trademarks 

ActiveX, DirectX, Microsoft, SQL Server, Visual Basic, Visual C++, 
Windows, Windows NT, Windows Server, and Windows Vista are either 
registered trademarks or trademarks of Microsoft Corporation in the United 
States and/or other countries. 

Acrobat, Adobe, and Reader are either registered trademarks or trademarks 
of Adobe Systems Incorporated in the United States and/or other countries. 

CIP, ControlNet, DeviceNet, and EtherNet/IP are either registered 
trademarks or trademarks of the ODVA, Inc. in the United States and/or 
other countries. 

IBM is a registered trademark of International Business Machines 
Corporation. 

OPC is a registered trademark of the OPC Foundation. 
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Oracle and SQL*Plus are either registered trademarks or trademarks of 
Oracle Corporation in the United States and/or other countries. 

Intel, Intel Core, and Pentium are either registered trademarks or trademarks 
of the Intel Corporation in the United States and/or other countries. 

All other trademarks are the property of their respective holders and are 
hereby acknowledged. 

Warranty 

This product is warranted in accordance with the product license. The 
product’s performance may be affected by system configuration, the 
application being performed, operator control, maintenance, and other related 
factors. Rockwell Automation is not responsible for these intervening factors. 
The instructions in this document do not cover all the details or variations in 
the equipment, procedure, or process described, nor do they provide 
directions for meeting every possible contingency during installation, 
operation, or maintenance. This product’s implementation may vary among 
users. 

This document is current as of the time of release of the product; however, 
the accompanying software may have changed since the release. Rockwell 
Automation, Inc. reserves the right to change any information contained in 
this document or the software at any time without prior notice. It is your 
responsibility to obtain the most current information available from Rockwell 
when installing or using this product. 

Environmental compliance 

Rockwell Automation maintains current product environmental information 
on its website at 
http://www.rockwellautomation.com/rockwellautomation/about-us/sustainabi
lity-ethics/product-environmental-compliance.page  

Contact Rockwell Automation 

Customer Support Telephone — 1.440.646.3434 

Online Support — http://www.rockwellautomation.com/support/  

 

http://www.rockwellautomation.com/rockwellautomation/about-us/sustainability-ethics/product-environmental-compliance.page
http://www.rockwellautomation.com/rockwellautomation/about-us/sustainability-ethics/product-environmental-compliance.page
http://www.rockwellautomation.com/support/
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Chapter 1 

Welcome to RSNetWorx for ControlNet 

RSNetWorx for ControlNet is a 32-bit Windows application program that 
lets you configure ControlNet networks. Using either a graphical or a 
spreadsheet representation of your network, you can configure network-wide 
parameters and generate the network-wide schedule for all nodes with a 
ControlNet scanlist. Also bundled with RSNetWorx for ControlNet is the 
Scanlist Configuration Tool (SCT), which is the scanner-specific 
configuration tool. This program lets you define scanlist entries for certain 
scanners and map scanner memory onto the network and network data into 
the scanner memory from within RSNetWorx for ControlNet. 

This chapter contains the following sections: 

 Features and benefits 

 Understanding ControlNet concepts 

 Exploring RSNetWorx for ControlNet 

 Quick Start steps 

RSNetWorx for ControlNet has the following features: 

 Support for FactoryTalk® Activation. If you are a new user, you must 
activate your software using FactoryTalk Activation. 

 Support for FactoryTalk Security. FactoryTalk Security is intended to 
improve the security of your automation system by limiting access to 
those with a legitimate need. FactoryTalk Security authenticates user 
identities and authorizes user requests to access a FactoryTalk-enabled 
system. These security services are fully integrated into the 
FactoryTalk Directory and are included as part of the FactoryTalk 
Services Platform that installs with many products. 

 Device usages view displays usage percentages for factors such as 
minimum and maximum CPU, and connection usages (when your 
device’s Electronic Data Sheet (EDS) file contains capacity 
information) or raw transmission data information (when your device’s 
EDS file does not contain capacity information). When edits are 
enabled, you will get to see both current and pending device usage 
information. 

 Embedded EDS is supported. With this functionality, you can now 
change the state of your device from unknown to known by uploading 
and registering its EDS, instead of obtaining the EDS file from an 
external website or a DVD. 

Features and benefits 
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 A Windows-based point and click interface that allows you to easily 
configure ControlNet networks. 

 Use of RSLinx Classic communication services, which allows you to 
browse online through various networks, devices, bridges, etc., to 
choose the network you want to view or edit. 

 The ability to optimize your network by configuring network 
parameters, such as network update time (NUT) and maximum 
scheduled or unscheduled addresses. 

 The ability to edit configurations either online or offline. 

 Simple and complete network upload/download. You can upload a 
configuration directly from the network or download a configuration to 
the online network. When you upload or download a configuration, 
both the ControlNet network configuration and the scanlist for the 
integrated scanners (PLC-5C processor, 1747 scanner) are transferred, 
as well as the network schedule for all scanners. 

 The Scanner Configuration Tool configures both I/O and peer-to-peer 
data addresses. Supports target devices for Rockwell Automation and 
third-party devices via ControlNet International standard Electronic 
Data Sheet (EDS) files. 

 Integration with RSLogix5 software (release 4.0 and higher), allowing 
you to configure, commission, and maintain a PLC-5C-based system 
on a ControlNet network. 

 Reports generated in HTML format. 

 Comprehensive context-sensitive online help, including additional 
information and troubleshooting hints on any message that appears in 
the Message View. 

 Quickly detect and resolve conditions that arise when initially 
commissioning a system, minimizing initial start-up times and costs. 

 Debug and correct network/device problems, thereby reducing network 
downtimes and related costs. 

 Detect preventive maintenance needs within the devices on your 
network, thereby preventing system downtimes. 
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You begin configuring your ControlNet network by determining how many 
devices will be connected to your network and the type of data the devices 
will be exchanging. ControlNet provides the capabilities to exchange data in 
both a scheduled and unscheduled fashion. (The details of the scheduling 
algorithms are presented in the ControlNet International specification.) 
Scheduled bandwidth is generally used for time critical, control process I/O 
data. Unscheduled data is generally used for less time critical I/O exchanges 
as well as configuration operations (for example, upload, download, or 
browse). RSNetWorx for ControlNet allows you to describe your scheduled 
traffic and execute the tasks necessary to distribute this schedule to the 
devices on your network, such as ControlLogix scanners, ControlNet 
PLC-5C processors, 1747 scanners, and other vendor’s scanners that follow 
the ControlNet International specification. Each device on the ControlNet 
network must be assigned a unique address. For devices sending scheduled 
data, assign a node address between 1 and the maximum scheduled node 
address. For all other devices, assign a node address between the maximum 
scheduled node address + 1 and the maximum unscheduled node address (for 
further information about the maximum scheduled and unscheduled node 
address, see page 4).  For example, if the maximum scheduled node address 
is 10 and the maximum unscheduled node address is 20, then the devices 
sending scheduled data would be given a node address between 1 and 10, and 
the devices sending unscheduled data would be given a node address 
between 11 and 20. 

To schedule the ControlNet network, you must determine your data update 
requirements. Typically you will set your Network Update Time (NUT) to 
the fastest data exchange required. The NUT is the basic unit of scheduling 
on the ControlNet network. It defines a periodic network cycle.  If a valid 
schedule was specified, each node whose address is between 1 and the 
maximum scheduled address will send its scheduled data (which is also 
scheduled for transmission) during the scheduled portion of the NUT.  If an 
invalid schedule was specified (too much scheduled data to be transmitted 
within the NUT), RSNetWorx informs you and you must either reduce the 
amount of scheduled data and/or change the NUT. After all scheduled traffic 
is transmitted within a NUT, unscheduled data is transmitted in round-robin 
fashion until the NUT expires. 

You may also define the maximum scheduled node address for your 
ControlNet network. This indicates the highest address that will be able to 
transmit in the scheduled (vs. unscheduled) portion of the NUT. As well as 
indicating the Maximum Scheduled Node Address, you may also configure 
the Maximum Unscheduled Node Address. This indicates the highest address 
that will be able to transmit any information on the ControlNet network. You 
enter these values into your configuration by utilizing the Network 
Parameters tab on the Network Property pages. 

Understanding ControlNet 
concepts 
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Tip: If the Maximum Unscheduled Node Address is set lower than the node address of 
the workstation that is communicating with the network, then the workstation 
won’t be able to successfully communicate with the network. You continue 
configuring your network by determining the physical layout of the devices, i.e., 
the amount of coaxial cable (to the nearest 100 meters) and/or the amount of fiber 
optic cable (to the nearest 100 meters) needed. Also, you need to know how many 
and what type of repeaters will be needed. Determine the longest path (in terms 
of delay time). This is the worst-case data path through the network. After you 
have defined this worst-case path, you use the Media Configuration tab on the 
Network property pages of the RSNetWorx for ControlNet software to enter the 
parameters of that path into your configuration file. 

Finally, you finish creating the configuration by defining connections 
between the nodes on the network. To do this, you determine which data is to 
be consumed by each scanner, and you determine where in each scanner’s 
data table this data is placed. You may also choose to determine which 
scanner will maintain the configuration for each adapter device. After you 
have defined these parameters, you use the Scanlist Configuration Tool (with 
integrated scanners) or Studio 5000 Logix Designer (with non-integrated 
scanners) to enter them into your configuration for each of your ControlNet 
scanners. 

For many devices, you can also use the Scanlist Configuration Tool to 
configure how outputs are set in the event of a fault, such as loss of 
communication to the controlling scanner. Depending on the information 
contained in a device’s EDS file, you may be able to configure other device 
parameters. These parameters may be found on the connection’s property 
page from the Configuration Settings tab and/or the Advanced Settings tab 
depending on the device or module for which you are setting the parameters.  
However, the PLC-5C processor requires the use of RSLogix 5 to set the 
Configuration Settings. 
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When you start RSNetWorx for ControlNet software, the RSNetWorx for 
ControlNet window appears. It shows the current network (ControlNet is the 
default network filename) in its view. The following illustration shows the 
RSNetWorx for ControlNet window and the design elements associated with 
it. (The Message view and Favorites view will not be automatically shown in 
the default view, but may be chosen by selecting View > Messages > Show 
or View > Favorites.)  Each of the design elements are described in the 
sections following this illustration. 

 

The title bar shows the RSNetworx icon, the name of the current 
RSNetWorx configuration, and the name of the software product. 

The RSNetWorx for ControlNet menu bar contains the following menus: 

 

Each menu contains options for performing the following tasks: 

Menu Description 

File New, print, open, and save a network configuration, generate reports, or exit RSNetWorx for ControlNet. 

Edit Invoke actions such as cut, copy, and paste on selected items in the network configuration. 

View Set and change RSNetWorx for ControlNet interface displays. 

Network Browse the network, toggle between online and offline mode, enable and cancel edits, and upload and 
download data to and from the network. 

Device Edit the properties of the selected device, chassis, or module. 

Tools Launch the EDS Wizard. 

Exploring RSNetWorx for 
ControlNet 

Title bar 

Menu bar 



Chapter 1 Welcome to RSNetWorx for ControlNet 

 

16 Rockwell Automation Publication CNET-GR001J-EN-E - November 2018 

Menu Description 

Help Access help options for RSNetWorx for ControlNet, ControlNet related hardware, and other Rockwell 
Software products and services. 

 

The online icon displays in the right side of the RSNetWorx for ControlNet 
window at the same level as the menu bar. 

 

This icon indicates whether or not RSNetWorx for ControlNet is in the 
online mode. If you toggle the Online toolbar button to online, the Online 
icon becomes animated. If the icon is not animated, RSNetWorx for 
ControlNet is in offline mode. When online, RSNetWorx for ControlNet 
writes information to the devices and to the offline file when you save. When 
offline, RSNetWorx for ControlNet only updates the offline file when you 
save. 

The toolbars contain shortcuts to several commonly used functions. Each 
toolbar button is a graphical representation of a command (except Symbol 
Legend) that is also available from the RSNetWorx for ControlNet menu bar. 
RSNetWorx for ControlNet contains the standard toolbar and the tools 
toolbar. 

The following items appear on the RSNetWorx for ControlNet standard 
toolbar. 

 

Icon Menu Selection Description 

 

File > New Creates a new network configuration. 

 

File > Open Opens an existing network configuration. The arrow to the right of the Open 
icon provides quick access to recently used files. 

 

File > Save Saves the current network configuration. 

 

File > Print Prints the current network configuration. 

 

Edit > Cut Cuts the selected device from the network configuration and place it on the 
clipboard. If you cut a device, only the device, not its configuration, is 
retained. 

Online icon 

Toolbars 
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Icon Menu Selection Description 

 

Edit > Copy Copies the selected device to the clipboard. If you copy a device, only the 
device type, not its configuration, is retained. 

 

Edit > Paste Pastes the device from the clipboard to the current network configuration. 

 

Help >  
What’s This? 

Places the cursor in What’s This? help mode. Place the cursor on the control 
you want help with and right-click to see the context-sensitive help. 

The following items appear on the RSNetWorx for ControlNet tools toolbar. 

 

Icon Menu Selection Description 

 

View > Zoom-In Increases the size of the images located in the current network 
configuration. The choices available are high, medium, and low. 
Zoom-In only applies to the graph view. 

 

View > Zoom-Out Decreases the size of the images located in the current network 
configuration. The choices available are high, medium, and low. 
Zoom-Out only applies to the graph view. 

 

View > Hardware Displays a list of all available hardware devices. 

 

View > Favorites Displays a list of hardware devices that you have added to your 
favorites list. 

 

Network > Single Pass 
Browse or Network > 
Continuous Browse 

Locates all currently available devices based on the drivers configured 
in RSLinx Classic. Allows you to browse once and stop (single pass) or 
browse continuously (continuous browse). 

 

Network > Online Places RSNetWorx for ControlNet in online mode. To go offline, click the 
button or choose Network > Online again. 

 

View > Diagnostics Displays the Diagnostic view, allowing you to view the diagnostic 
parameters for all of the devices on your network, and indicates the 
current diagnostic status of your network. 

 

View > Refresh Refreshes the window. This will reorder the graphic display by device 
address. 

 
No menu selection Displays the Symbol Legend, which contains descriptions of the device 

comparison states. The Symbol Legend can also be accessed from the 
online help system by selecting Help > Contents and selecting 
symbol legend from the index tab. 
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The Network Usage area allows you to obtain the edit resource, enabling and 
disabling edits to the current ControlNet offline configuration file (*.xc) and 
online network, while also displaying statistics such as current and pending 
network update time and scheduled bandwidth. 

 

A device can be added to the network configuration by selecting it from the 
Hardware view and dragging it to the configuration (graph or spreadsheet 
view). Once a device is added, it will display in the appropriate 
configuration. The Favorites view displays all hardware devices that you 
have defined as favorites by selection from the Hardware list. To add an item 
from the Hardware list to the Favorites list, select the item, right-click and 
choose Add to Favorites. 

 

Network usage 

Hardware and Favorites views 

Graph or Spreadsheet view
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The application workspace displays network information in either a graphic 
or a spreadsheet view. Click on the appropriate tab in the network 
configuration to display the desired view. 

 

 

Diagnostics view 
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RSNetWorx Diagnostics provides a hierarchal view of the real-time status 
(or health) of a network. At a glance, you can quickly and easily determine 
the overall status of your network, or any device on your network, by 
viewing a single status indicator. Click the Diagnostics tab in the network 
configuration to display this view. 

 

The message view, which appears in the bottom portion of the workspace, 
displays a log of messages. Each message consists of four parts: 

 an icon that indicates error, warning, or information. 

 an error code (including a distinguishing software component 
designator and a 16-bit numeric designator) 

 a timestamp that displays the date and time the message is generated 

 a description of the message 

Tip: If View > Messages has not been previously selected, the Message View will 
automatically appear when a message is logged by RSNetWorx for ControlNet. 
If you want more information on any particular message, you can select the 
message and press the F1 key to access the online help. You can Show, Clear, Copy, 
or Clear and Hide messages by making the appropriate selection from the View > 
Messages command on the main menu, or by right-clicking and selecting the 
Message option while in the Message view. 

 

The status bar, which is located at the bottom of the RSNetWorx for 
ControlNet main window, provides information about the status of the 
software. 

The left portion of the status bar displays informational messages about the 
operation of RSNetWorx for ControlNet software. For example, when you 
highlight a device in the application workspace, a brief description of that 
device appears on the status bar. 

Message view 

Status bar 
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The right portion of the status bar displays the current state of the browsing 
operation. 

 

The Scanlist Configuration Tool is an extension of the RSNetWorx software 
that allows you to create, modify, and delete connection entries within a 
scanlist (for example, a PLC-5 processor). Using the Scanlist Configuration 
Tool, you can establish connections among devices and their respective I/O 
components (identifying data types, sizes, and timing intervals) and then map 
that information to the data table. The following illustration shows the 
Scanlist Configuration Tool window and the design elements associated with 
it. (The Message view will not be automatically shown in the default view, 
but may be chosen by selecting View > Messages > Show.) Each of the 
design elements are described in the sections following this illustration. 

 

The title bar shows the Scanlist Configuration Tool icon, the name of the 
selected scanner, the name of the software product and so on. 

The Scanlist Configuration Tool menu bar contains the following menus: 

 

Each menu contains options for performing the following tasks: 

Menu Description 

File Save a configuration, generate a report for this scanner, or exit the Scanlist Configuration Tool. 

Edit Invoke actions such as cut, copy, and paste on selected items in the configuration. 

View Set and change the Scanlist Configuration Tool interface displays. 

Exploring the Scanlist 
Configuration Tool 

Title bar 

Menu bar 



Chapter 1 Welcome to RSNetWorx for ControlNet 

 

22 Rockwell Automation Publication CNET-GR001J-EN-E - November 2018 

Menu Description 

Network Toggle between online and offline mode, and enable or cancel edits. 

Device Change mode of the scanner from, for example, run to program mode or download to device. 

Connection Insert connections or change connection parameters. 

Help View help options for the Scanlist Configuration Tool and other Rockwell Software products and 
services. 

 

The online icon displays in the right side of the Scanlist Configuration Tool 
at the same level as the menu bar. 

 

This icon indicates whether or not RSNetWorx for ControlNet is in the 
online mode. If you toggle the Online toolbar button to online, the Online 
icon becomes animated. If the icon is not animated, RSNetWorx for 
ControlNet is in offline mode. When online, RSNetWorx for ControlNet 
writes information to the devices and to the offline file when you save. When 
offline, RSNetWorx for ControlNet only updates the offline file when you 
save. 

The toolbars contain shortcuts to several commonly used functions. Each 
button on the toolbars is a graphical representation of a command that is also 
available from the Scanlist Configuration Tool menu bar. 

The following items appear on the Scanlist Configuration Tool toolbar. 

 

Icon Menu Selection Description 

 

File > Save Saves the current network configuration. 

 

Edit > Cut Cuts the selected field value and places it on the clipboard. 

 

Edit > Copy Copies the selected field value to the clipboard. 

 

Edit > Paste Pastes the field value from the clipboard to the current network 
configuration. 

 

Connection > Auto Insert > 
All Devices 

Interrogates all devices that can have connections on the 
ControlNet configuration and adds connections to  
the scanlist. 

Online icon 

Toolbar 
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Icon Menu Selection Description 

 

Connection > Auto Insert > 
Selected Devices 

Interrogates selected devices that can have connections in the 
ControlNet configuration and adds connections to the scanlist. 

 

Connection > Auto Address > 
All Entries 

Auto maps all unmapped addresses in all entries. 

 

View > Connection Configuration Displays information respective to the selected connection. 

 

View > Connection Status Switches the view to a display of the status of each connection. 

 

Network > Online Places the Scanlist Configuration Tool in online mode. To go offline, 
click the button or choose Network > Online again. This button is 
unpressed when in online mode. 

 

Help > What’s This? Places the cursor in What’s This? help mode. Place the cursor on the 
control you want help with and right-click to see the 
context-sensitive help. 

 

Within the Scanlist Configuration Tool, you can also view all of the network 
aspects related to the selected node, including node memory usage, node 
network usage, and overall network usage. With this information, you can 
easily make changes to any scanlist and readily identify how your changes 
affect the ControlNet network. 

 

Resource usage 

Scanlist entries 
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The scanlist entries enable you to perform tasks such as defining the 
connection targets and inserting connections for the selected devices. You 
must be in edit mode to edit these entries. 

 

File settings are only available for the PLC-5C processor. The file settings 
enable you to define the files to be used by the scanlist entries for the 
selected device. You must be in edit mode to edit these files. If you choose 
the auto address command, the necessary files are selected for you; 
otherwise, you can specify your own files. 

 

The status bar, which is located at the bottom of the Scanlist Configuration 
Tool window, provides information about the status of the software and the 
scanner. 

The left portion of the status bar displays informational messages about the 
operation of the configuration software. For example when you mouse over a 
toolbar icon, a brief description of that icon appears on the status bar. 

The right portion of the status bar displays the following information: 

 Online mode - Offline or Online 

 Edit mode - Monitor or Edit 

 Scanner type, series, and revision 

 Address number 

 Scanner mode - Remote Program, Program, Remote Run, or Run 

 

File settings 

Status bar 
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The fastest way to configure your ControlNet network is to let the 
RSNetWorx for ControlNet software browse your online network for 
ControlNet devices and automatically add them into your configuration. 
Then, let the Scanlist Configuration Tool automatically configure 
connections to your target devices. You can follow this same procedure for 
configuring your network in the offline mode by manually dragging and 
dropping devices from your Hardware tab into your network configuration. 

For some devices, you need additional RSLogix software to complete your 
network configuration.  Refer to the following table: 

If you have the following device in 
your network: Use this software to complete your configuration: 

PLC-5C processors RSLogix 5 

SLC scanners RSLogix 500 

ControlLogix processors Studio 5000 Logix Designer 
Important: There is no offline mode when working with ControlLogix processors. Also, for 
more information on using Studio 5000 Logix Designer and ControlLogix processors, refer 
to the online help for the Scanlist Configuration Tool. 

This section walks you through the tasks you will need to perform to use 
RSNetWorx for ControlNet software in both the online and offline modes. 
To remain focused on the high-level nature of each task and on the flow of 
these tasks, the following steps do not include the step-by-step procedure for 
accomplishing each task. When you are ready to use RSNetWorx for 
ControlNet software, you should follow the detailed procedures found in the 
Quick Start, which is located in the RSNetWorx for ControlNet online help. 

To access the software’s quick start, select Help > Quick Start from the 
RSNetWorx for ControlNet window. To see information about any control 
on the RSNetWorx for ControlNet or Scanlist Configuration Tool windows, 
remember to use the What’s This? help. 

Step 1 - Create a new configuration and browse for an online network 

The first step in using RSNetWorx for ControlNet in the online mode is to 
create a new ControlNet configuration. Once you create the configuration, an 
empty network displays in the network configuration. 

Next, go online and select a communication driver using the RSWho browse 
utility. A graphical representation of the selected network appears in the 
network configuration. If you would like to see a tabular view of the 
information instead of the graphical view, click the Spreadsheet tab. 

Step 2 - Configure your ControlNet network and save your configuration 

After creating your new configuration and going online, you must configure 
your ControlNet network by enabling edits to obtain the edit resource for the 
network. Once you obtain the edit resource for the network, no other 

Quick Start steps 

Online mode 
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individual can simultaneously edit the online network or the associated .xc 
file.  Enabling edits also obtains exclusive write access to the .xc file.  
Editing your network properties consists of tasks such as entering the media 
configuration information, and setting network parameters (for example, 
maximum scheduled node and maximum unscheduled node). 

Tip: At various times, you may want to save the work you have completed on your 
network configuration. To save a configuration file (*.xc), click File > Save. If you 
save, keep in mind that you will lose the edit resource. To obtain the edit resource 
again, click the Edits Enabled checkbox. 

Step 3 - Start the Scanlist Configuration Tool and insert a connection 

The Scanlist Configuration Tool is a software tool used to create, modify, 
and delete scanlist entries in a scanner. This tool also allows you to define 
how particular devices communicate on the network. To configure devices 
that contain an internal scanlist (for example, a PLC-5 processor), use the 
Scanlist Configuration Tool. Once you open the Scanlist Configuration Tool, 
you can either insert connections to other devices on the network manually, 
or you can use the auto insert feature within the Scanlist Configuration Tool 
to automatically insert the scanlist entries. 

Step 4 - Define a connection target and save your schedule 

To provide data from the scanner to other devices on the network, you must 
define a connection target. You can define the connection target for the 
scanner nodes on your network manually. After defining your connection 
targets, the final step is to save your configuration schedule and exit the 
Scanlist Configuration Tool. 

Step 5 - Diagnose and troubleshoot your online network 

Once you save your configuration, you can diagnose the network and 
determine the status of all of the devices on that network. If any of the 
devices are exhibiting diagnostics problems, you can troubleshoot those 
devices and return your network to proper operating condition. 

Step 6 - Schedule network diagnostics 

After diagnosing and troubleshooting your online network, you can schedule 
diagnostics to occur for each network that has associated offline 
configuration file (*.xc) developed in RSNetWorx, allowing you to support 
an unattended, background mode of diagnostic operation. Further, via the 
RSNetWorx Diagnostics Service Monitor, you can start, stop, and establish 
the startup mode for each network diagnostic schedule that you have 
configured. 

Offline mode 
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Step 1 - Create a new configuration and describe your network topology 

The first step in using RSNetWorx for ControlNet in the offline mode is to 
create a new ControlNet configuration (File > New). Once you create the 
configuration, an empty network displays in the network configuration. 

Next, Enable Edits to obtain exclusive write access to the offline 
configuration file (*.xc). After you obtain the edit resource, no other 
individual can simultaneously edit the offline configuration file. In the edit 
mode, you can describe your network topology by double-clicking on an 
available device or by dragging it from the Hardware tab and dropping it into 
the network configuration. When you are finished, a graphical representation 
of the selected network appears in the network configuration. If you would 
like to see a tabular view of the information instead of the graphical view, 
click the Spreadsheet tab. 

Step 2 - Configure your ControlNet network and devices 

After creating your new configuration, you must configure your ControlNet 
network and devices. This consists of tasks such as entering the media 
configuration information, and setting network parameters (for example, 
maximum scheduled node and maximum unscheduled node). 

Tip: At various times, you may want to save the work you have completed on your 
network configuration. To save a configuration file (*.xc), click File > Save. If you 
save, keep in mind that you will lose the edit resource. To obtain the edit resource 
again, click the Edits Enabled checkbox. 

Step 3 - Start the Scanlist Configuration Tool and insert a connection 

The Scanlist Configuration Tool is a software tool used to create, modify, 
and delete scanlist entries in a scanner. This tool also allows you to define 
how particular devices communicate on the network. To configure devices 
that contain an internal scanlist (for example, a PLC-5C processor), use the 
Scanlist Configuration Tool. Once you open the Scanlist Configuration Tool, 
you can either insert connections for the scanner nodes on your network 
manually, or you can use the auto insert feature within the Scanlist 
Configuration Tool to automatically insert the scanlist entries. 

Step 4 - Define a connection target and save your schedule 

To provide data from the scanner to other devices on the network, you must 
define a connection target. You can define the connection target for the 
scanner nodes on your network manually. After defining your connection 
targets, the final step is to save your configuration schedule and exit the 
Scanlist Configuration Tool. 

 





 

 Rockwell Automation Publication CNET-GR001J-EN-E - November 2018 29 

Chapter 2 

Installing and starting RSNetWorx for ControlNet 

This chapter explains how to install and start RSNetWorx for ControlNet 
software. This chapter includes information on the following: 

 system requirements 

 software compatibility 

 installation methods 

 installation procedure 

 starting procedure 

 troubleshooting 

After installing the software, we recommend that you read the release notes 
located in the online help. The release notes may contain more up-to-date 
information than was available when this document was published. To view 
the release notes, start RSNetWorx for ControlNet, and then choose Help > 
Release Notes from the main menu. 

To run RSNetWorx for ControlNet, your system must meet the following 
hardware and software requirements: 

To run RSNetWorx for ControlNet, your system must meet the following 
hardware requirements: 

 An Intel® Core™ 2 Duo processor running at 2.8 GHz or faster or 
another processor with equivalent specifications 

 4 GB or more memory RAM 

 At least 16GB of available hard drive space 

 

To run RSNetWorx for ControlNet, you require one of the following 
operating systems: 

 Windows 10 Enterprise v1803 

 Windows 10 Professional v1803 

 Windows 10 Enterprise v1709 

 Windows 10 Professional v1709 

System requirements 

Hardware requirements 

Software requirements 



Chapter 2 Installing and starting RSNetWorx for ControlNet

 

30 Rockwell Automation Publication CNET-GR001J-EN-E - November 2018 

 Windows 10 Enterprise v1703 

 Windows 10 Professional v1703 

 Windows 7 Ultimate with Service Pack 1 

 Windows 7 Enterprise with Service Pack 1 

 Windows 7 Professional with Service Pack 1 

 Windows Server 2016 Standard 

 Windows Server 2016 Datacenter 

 Windows Server 2012 Standard 

 Windows Server 2012 Datacenter 

 Windows Server 2012 R2 Standard 

 Windows Server 2012 R2 Datacenter 

 Windows Server 2008 R2 Standard with Service Pack 1 

 Windows Server 2008 R2 Enterprise with Service Pack 1 

 

RSNetWorx for ControlNet version 28.00 is a component aligned to Studio 
5000 Logix Designer™ version 32.00. This version of RSNetWorx has been 
tested with, and is compatible with, the following products: 

 FactoryTalk® Activation Manager version 4.03 

 FactoryTalk® Services Platform version 6.10 

 RSLinx® Classic version 4.10 

 RSLogix™ 5 version 9.00 

 RSLogix 500® version 12.00 

 Studio 5000 Logix Designer® version 32.00 

It is recommended that you use all products from the same CPR release. 

RSNetWorx supports two installation methods: Setup wizard installation and 
unattended installation. 

The unattended installation reduces user interaction and provides command 
line parameters to install RSNetWorx. For more information, see Use 
unattended installation on page 81. 

This chapter uses the Setup wizard installation method to illustrate the steps. 

Software compatibility 

Installing RSNetWorx for 
ControlNet software 
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Tip: While installing RSNetWorx for ControlNet software, you will have the opportunity 
to specify a directory. The default directory is: 
x:\Program Files\Rockwell Software\RSNetWorxII 
where x is the drive where the operating system is installed. 
We recommend that you use the default directory whenever possible. This 
subdirectory contains all of the application files required to run the product. 
In procedures that appear throughout this document, it is assumed that you used 
the default name. If you did not use the default name, substitute the actual name 
you specified for the default name shown. 

To install RSNetWorx for ControlNet software, perform the following steps: 

1. Launch the installation wizard and select what to install. 

2. Set up security in RSNetWorx. 

3. Read and accept license agreements. 

4. Start the installation. 

5. Finish the installation. 

1. Close all open programs. 

2. In the RSNetWorx installation package, double-click Setup.exe. 

3. If Microsoft .NET Framework 4 is not installed on your computer, the 
Microsoft .NET Framework Setup dialog box shows. Click Install. 

 

Step 1: Launch the installation 
wizard and select what to 
install 
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4. On the RSNetWorx Setup page, select a language to be shown during 
the installation process if needed. By default, your system language is 
selected. 

 

5. To install RSNetWorx for ControlNet, RSNetWorx for EtherNet/IP, 
and RSNetWorx for DeviceNet, click Install now and skip to Step 2: 
Read and accept license agreements on page 34. 

6. To select a particular software product, click Customize. 
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7. On the Customize page, select RSNetWorx for ControlNet 
v27.00.00 and its components. 

 

8. Select the location for Rockwell Automation software. The default 
location is C:\Program Files (x86)\Rockwell Software. 

9. Click Next. 

On this page, you can set up FactoryTalk Security in RSNetWorx to improve 
the security of your automation system by limiting access to those with a 
legitimate need. 

Step 2: Set up security in 
RSNetWorx 
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1. Select the Enable FactoryTalk® Security option. And then select the 
FactoryTalk directory (Network or Local) that will be used to 
authenticate and authorize user access. 

 

2. Click Install. 

 

End-user license agreements (EULA) spell out your rights and 
responsibilities. Depending on the components being installed, there may be 
more than one license agreement on this page. The individual license 
agreements are listed above the text box. 

Step 3: Read and accept license 
agreements 
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Tip: You can also view the license agreements from the License folder of RSNetWorx 
installation package. 

Some software products may be delivered or made available only after you 
agree to the terms and conditions of each of the license agreements. 

1. On the End User License Agreements page, select each agreement 
and read the agreement carefully. 

2. When all license agreements have been read, click Accept All. 

 

Step 4: Start the installation 
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After accepting the license agreements, the Setup Wizard automatically 
installs all the Rockwell Software applications selected previously. 

 



Installing and starting RSNetWorx for ControlNet Chapter 2 

 

 Rockwell Automation Publication CNET-GR001J-EN-E - November 2018 37 

During the installation, if prompted to restart your computer, click Restart 
now. 

 

Step 5: Finish the installation 
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After the installation completes, you need to activate the software for its full 
feature capabilities. You can activate the software now or late. For more 
information about activation, see Activation on page 73. 

 

 To active the software, select Activate your software and click Next. 
Make sure your computer is connected to the Internet. 

In the Software Activation dialog box, enter the required information 
and click Continue. 
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You will be prompted to restart the computer after the activation. 

 

 To finish the installation without activation, Select Skip activation and 
click Next. 
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 To view the installation details, click Installation Summary. 

 To receive latest product updates and patch notification, click 
Register for updates. 

 To install the latest version of Adobe Acrobat Reader, click 
Download it free and follow the on-screen instructions. 

Restart the computer to complete the installation. 

 

As a client to a client-server installation, you can install one or more 
Rockwell Software products from the dedicated server location to an 
end-user destination. To install the RSNetWorx for ControlNet software 
from the server, perform the following steps: 

1. Map a network drive to the dedicated server location provided by your 
system administrator. The system administrator must have copied the 
entire installation contents and provided only Read and Execute 
permissions of the files. Users installing the software cannot have write 
access to the files. 

2. Double-click Setup.exe in the client installation directory. 

Installing a client copy from a 
dedicated server 
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3. See the Installing RSNetWorx for ControlNet software on page 30 
section in this chapter. 

To start RSNetWorx for ControlNet software, click Start > All Programs > 
Rockwell Software > RSNetWorx > RSNetWorx for ControlNet. 

If RSNetWorx for ControlNet does not start up or run properly, consider the 
following: 

 Do you have the correct version of RSLinx Classic installed? 
RSNetWorx for ControlNet requires RSLinx Classic version 4.00. 

 Does your computer have enough memory? RSNetWorx for 
ControlNet requires a minimum of 4GB of RAM. 

 Have you reinstalled an earlier Service Pack, or removed a component, 
such as DCOM, that RSNetWorx for ControlNet requires? 

 Have you checked the RSNetWorx support on the web for 
troubleshooting information? Go to 
http://www.rockwellautomation.com/support/ , click Knowledgebase, 
and search for Tech Notes on RSNetWorx for ControlNet. 

 Do you have the up-to-date compatibility information for the software? 
Go to Product Compatibility and Download Center at 
https://compatibility.rockwellautomation.com/Pages/home.aspx . 

 

Starting RSNetWorx for 
ControlNet 
Troubleshooting 
installation 

http://www.rockwellautomation.com/support/
https://compatibility.rockwellautomation.com/Pages/home.aspx
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Chapter 3 

Advanced concepts 

This chapter contains the following sections: 

 EDS-based devices 

 Class Instance Editor 

 ControlNet versus Remote I/O and DH+ networks 

 RSLogix 5 and RSNetWorx integration 

RSNetworx for ControlNet relies on an electronic data sheet (EDS) for 
configuring devices. An electronic data sheet is an ASCII file that is created 
by the manufacturer and supplied with the device. 

As long as the EDS file for the device you want to configure is registered 
with the RSNetWorx for ControlNet software, you can configure its target 
connection configuration (attributes) and how it will communicate with other 
devices on the ControlNet network. Although the procedure for configuring a 
device is basically the same for all devices, each device has a unique set of 
properties. 

The electronic data sheet (EDS) library is a collection of EDS files that have 
been registered with RSNetWorx for ControlNet. The EDS files, which are 
provided by the device manufacturers, contain configuration and 
identification information for the devices. 

RSNetWorx for ControlNet software can access only those devices that have 
been registered. You must use the EDS Registry Wizard for registering EDS 
files for unknown devices, or if you have updated EDS files to install. To 
access the EDS Wizard, select Tools > EDS Wizard. 

Although you get a large number of electronic data sheet (EDS) files with the 
RSNetWorx for ControlNet software, there may be a time when you need to 
acquire/create additional EDS files. The most common ways to get these files 
are to: 

 obtain them on distribution media that accompany the devices. 

 download them from ControlNet sites on the world wide web. You can 
either select the device in the network configuration, right-click the 
mouse and select Re-register Device, and click Download EDS File in 
the EDS Wizard or access one of the following world wide web sites 
from which EDS files are available: 

EDS-based devices 

EDS library 



Chapter 3 Advanced concepts 

 

44 Rockwell Automation Publication CNET-GR001J-EN-E - November 2018 

 http://www.odva.org  (ODVA organization website) 

 https://www.rockwellautomation.com/global/support/networks/eds.
page?  (Allen-Bradley technical support site) 

 download them from a different manufacturer’s site. 

The Class Instance Editor is a tool that allows you to send data to, and read 
data from, a ControlNet device that is not otherwise configurable with 
RSNetWorx for ControlNet. Using the Class Instance Editor you can either 
enter raw data and download it to the device, or read the data from the 
device. 

Important: We do not recommend configuring devices with the Class Instance Editor 
unless you are instructed to do so by technical support personnel for the 
hardware product. 

To use the editor, you will need to know the service code, class, instance, and 
attribute by their appropriate hexadecimal codes within the device. This 
information may be on the printed data sheet accompanying the device. 

Tip: For further information about configuring a device with the Class Instance Editor, 
contact the manufacturer of the device. For more information on how to enter data 
into the Class Instance Editor, contact Rockwell Automation technical support. 

 

Because ControlNet combines the functionality of an I/O network with that 
of an informational network, you can use it in place of using Remote I/O and 
DH+ or Remote I/O and Ethernet networks in combination. However, when 
you design your architecture, keep the following considerations in mind. 

 The ControlNet network is designed optimally for predictable and 
repeatable delivery of scheduled data (much like the Remote I/O 
network). This design also provides for the delivery of unscheduled 
data, like the DH+ network, but makes it difficult to predict 
unscheduled data transfer performance. 

 ControlNet and Ethernet are not equivalent networks and they are 
designed for different purposes. Used correctly, these networks are 
complementary but not competitive. Therefore, be aware that if you 
use ControlNet for applications with predominant or heavy 
unscheduled traffic, you may be misapplying the network. 

Data delivery for traffic on an Ethernet network is designed for 
first-come, first-served delivery. Therefore, the delivery of a particular 
message on a lightly loaded Ethernet network could be faster than on 
ControlNet. Also, for comparison, one maximum-size Ethernet 
message (750 words) may be substituted with as many as seven 
ControlNet unscheduled messages. 

As a rule, if you expect to use small, unscheduled packets with fewer 
than 100 words and do not expect heavy unscheduled network traffic, 

Class Instance Editor 

ControlNet versus Remote 
I/O and DH+ networks 

http://www.odva.org/
https://www.rockwellautomation.com/global/support/networks/eds.page?
https://www.rockwellautomation.com/global/support/networks/eds.page?
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you can use either ControlNet or Ethernet for unscheduled messaging 
with comparable performance. If you expect to use larger packets and 
heavy traffic, you should use the Ethernet network. 

 The PLC-5/C15 processor implementation of ControlNet 1.5 
unscheduled messaging simulates Programmable Controller 
Communication Command (PCCC) messaging and therefore, does not 
support more than 128 words in a single message packet (versus 255 
words maximum allowable). As a result, PLC-5/C15 processors must 
work twice as hard to send/receive unscheduled messages on 
ControlNet. 

 Buffer limitations are device-specific and can affect the total number of 
messages handled by that device, thereby affecting overall 
performance. The following table provides information about available 
product buffers for unscheduled connected and unconnected 
messaging. 

Product Connected Unconnected 

PLC-5/C processor 32 20 

1784-KTCx module 25 20 

1756-CNB module 64* 20/5** 

*This is not a fixed value; it is determined by the Network Update 
Time (NUT). 

**The limit is five prior to firmware release A01.19 of the module and 
20 with firmware release A01.19 and later. 

By their nature, connected messages require the use of buffers for longer 
periods of time than do unconnected messages because the connection—and 
thus the buffer—remains in use until the connection is ended. By contrast, 
with unconnected messages, a connection, and its buffer, remains in use for 
only short periods of time. 

This section contains the following topics: 

 Online without Allen-Bradley remote I/O (RIO) usage 

 Offline without Allen-Bradley remote I/O (RIO) usage 

 Offline with Allen-Bradley remote I/O (RIO) usage 

 Online with Allen-Bradley remote I/O (RIO) usage 

To quickly and effectively use RSNetWorx for ControlNet and RSLogix 5 in 
the online mode when Allen-Bradley remote I/O (RIO) is not a 
consideration, perform the following steps: 

Tip: These steps assume that you have configured a communication driver with RSLinx 
Classic for communication to your ControlNet network. 

 Define the network layout 

RSLogix 5 and RSNetWorx 
integration 

Online without Allen-Bradley 
remote I/O (RIO) usage 
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 Insert connections 

 Associate an RSLogix 5 project file (*.rsp) with each PLC-5C node in 
the ControlNet configuration file (*.xc) and specify module 
configuration information 

 Integrate RSLogix 5 edits 

 Synchronize the RSLogix 5 project file (*.rsp) with the online PLC-5C 

1. In RSNetWorx for ControlNet, define the hardware layout of your 
ControlNet network. Complete the following: 

a. Start RSNetWorx for ControlNet and select Network > Online. 

b. On the Browse for Network dialog, select a communication path to 
your ControlNet network, and then click OK. Allow the entire 
browse operation to complete before proceeding to step c. 

c. Click the Edits Enabled checkbox. 

Tip: If the Online/Offline Mismatch dialog appears, choose the use offline data 
(download) option, and then click OK. 

 

1. In RSNetWorx for ControlNet, define the connections needed by the 
PLC-5C for ControlNet communication. To define these connections, 
complete the following: 

a. In the network configuration, click a PLC-5C processor and then 
select Device > Scanlist Configuration. RSNetWorx for 
ControlNet launches an instance of the Scanlist Configuration Tool 
and displays the scanlist for the selected PLC-5C processor. 

The PLC-5C you are currently configuring is highlighted in green. 
In addition, the node address of the PLC-5C is also displayed in the 
title bar. 

b. Click the device that you want to insert a connection to, then select 
Connection > Insert. On the Connection Properties dialog, specify 
all of the ControlNet configuration properties associated with that 
connection. When complete, click OK. 

Repeat for each device that you want to connect to on your 
ControlNet network. 

Define the network layout 

Insert connections 
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Tip: You can insert default connections to all of the devices on the ControlNet network 
or a selected set of devices on the ControlNet network. Select Connection > Auto 
Insert > All Devices to search all of the devices in the configuration and insert a 
pending connection entry. Select Connection > Auto Address > All Entries to 
allow the software to select the next available, unconfigured address and define 
theControlNet specific files (for example, status, configuration, data input, and 
data output) needed for each connection. 

2. Repeat step 1 of this section for each PLC-5C on your ControlNet 
network. 

Tip: Keep in mind that a separate instance of the Scanlist Configuration Tool will be 
launched for each PLC-5C that you are actively editing on your ControlNet network. 

3. In RSNetWorx for ControlNet, select File > Save to save your work to 
the ControlNet configuration file (*.xc). You will associate individual 
RSLogix 5 project files (.rsp) to this file in the following sections. 

When complete, minimize each instance of the Scanlist Configuration 
Tool. Then minimize RSNetWorx for ControlNet. 

1. In RSLogix 5, create a new project for a PLC-5C processor and 
associate the project to the configuration file (*.xc) created in 
RSNetWorx for ControlNet. Complete the following: 

a. Start RSLogix 5, and then select Comms > Who ActiveGo 
Online. 

b. In the Communications dialog, select a PLC-5C processor node, 
and then click OK. 

c. On the Default Program Rename dialog, enter a name for the 
selected PLC-5C processor, and then click OK. The processor 
image is uploaded to the RSLogix 5 project file (*.rsp) 

Tip: If the PLC-5C already has a name, the Going to Online dialog is displayed. Click 
Create New File. 

d. In the Project tree control, select the Controller Properties icon. 
Click the right mouse button and select Open. On the Controller 
Properties dialog, browse your computer to find the ControlNet 
configuration file (*.xc) that you created in steps 1 and 2 of the 
Insert connections on page 46 section. In addition, be sure to 
specify the node address where the selected PLC-5C resides on 
your ControlNet network, and then click OK. 

Associate an RSLogix 5 project file 
(*.rsp) with each PLC-5C node in the 
ControlNet configuration file (*.xc) 
and specify module configuration 
information 
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Tip: It is not necessary to enter a value for the ControlNet Source Link ID field. For more 
information on the ControlNet Source Link ID field, see the RSLogix 5 online help. 

2. Configure each module and store the configuration data in the 
processor’s data table. To define these locations in RSLogix 5, 
complete the following: 

a. In the Project tree control, select the I/O Configuration icon. Click 
the right mouse button and select Open. On the I/O Configuration - 
Chassis Table dialog, all of the devices that this processor 
communicates with and associated I/O mapping information are 
displayed. 

b. Select the chassis that contains the module that you want to 
configure on the ControlNet network. Click the right mouse button 
and select Display Chassis. Each of the modules that this PLC-5C 
communicates with in that chassis are automatically added and 
displayed by RSNetWorx for ControlNet. 

c. Select the module type in that chassis that you want to configure. 
Click the right mouse button and select Display Module. On the 
Module Configuration dialog for the selected module, configure 
the module for your application. When complete, click Accept 
Edits, and then click Close. Close all of the associated dialogs. 

Repeat for each module in that chassis (if applicable). 

d. You are prompted to download the configuration to the module. 
Click OK. 

3. Enter the appropriate ladder logic for the PLC-5C processor. 

4. Save the RSLogix 5 project file (*.rsp) for this PLC-5C processor. You 
are prompted to upload current data table values; click Yes. At this 
point, the changes are committed to the specified RSLogix 5 project 
file and all pending edit information is included in the associated .xc 
file. 

When complete, close the RSLogix 5 project file. 

5. Repeat steps 1 through 4 of this section for each PLC-5C processor on 
your ControlNet network. 

Tip: Be sure to specify a unique ControlNet node number for each PLC-5C processor on 
your ControlNet network. 

When complete, minimize RSLogix 5. 
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1. In RSNetWorx for ControlNet, integrate the changes made in RSLogix 
5 for each PLC-5C on the network to the configuration file (*.xc) 
created in the Define the network layout on page 46 and Insert 
Connections on page 46 sections. Complete the following: 

a. Maximize RSNetWorx for ControlNet and select the Edits Enabled 
checkbox. All changes made in RSLogix 5 are automatically 
included as pending edits. 

Tip: In each instance of the Scanlist Configuration Tool, you can review the changes 
made to the modules in RSLogix 5. These changes appear in blue text (pending 
edits). 

b. In RSNetWorx for ControlNet (or any instance of the Scanlist 
Configuration Tool), select File > Save to incorporate all of the 
pending RSLogix 5 changes into the associated *.xc file. On the 
Save configuration dialog, select the correct save option and click 
OK. 

c. Minimize each instance of the Scanlist Configuration Tool. 

Your system configuration is now complete. 

1. In RSLogix 5, open each project file (*.rsp) that was created for each 
PLC-5C node on your network. Complete the following: 

a. Open a RSLogix 5 project file (*.rsp). 

b. Select Comms > Upload to save the network configuration in the 
ControlNet configuration file (*.xc). Your offline network should 
match your online network. 

c. Select Comms > Go Online. 

Tip: If you are prompted to save changes, click Yes. 

d. Select Remote Run mode. 

2. Repeat for each RSLogix 5 project file (*.rsp). When complete, 
RSLogix 5 and RSNetWorx for ControlNet are synchronized. 

For more information about the integration of RSLogix 5 and RSNetWorx 
for ControlNet, contact Rockwell Software Technical Support. 

To quickly and effectively use RSNetWorx for ControlNet and RSLogix 5 in 
the offline mode when Allen-Bradley remote I/O (RIO) is not a 
consideration, and then download that information to your online network, 
perform the following steps: 

Integrate RSLogix 5 edits 

Synchronize the RSLogix 5 project file 
(*.rsp) with the online PLC-5C 

Offline without Allen-Bradley 
remote I/O (RIO) usage 
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Tip: These steps assume that you have configured a communication driver with RSLinx 
Classic for communication to your ControlNet network. 

 Define the network layout 

 Define the local rack information and insert connections 

 Associate an RSLogix 5 project file (*.rsp) with each PLC-5C node in 
the ControlNet configuration file (*.xc) and specify module 
configuration information 

 Integrate RSLogix 5 edits 

 Download the ControlNet configuration file (*.xc) that contains the 
PLC-5C scanlist 

 Download and synchronize the RSLogix 5 project file (*.rsp) with the 
online PLC-5C 

1. In RSNetWorx for ControlNet, define the hardware layout of your 
ControlNet network. Complete the following: 

a. Start RSNetWorx for ControlNet and click the Edits Enabled 
checkbox. 

b. In the Hardware view, select one of the devices on your 
ControlNet network (for example, PLC-5C or adapter module) and 
drag it to the network configuration area (either the Graph or 
Spreadsheet view). RSNetWorx for ControlNet automatically 
assigns the next available node number to the device; if it is not 
acceptable for your application, change the node number 
accordingly. 

Repeat for each device on your ControlNet network. 

c. Click an adapter module in the network configuration and specify 
the contents of the chassis by selecting Device > Define Chassis. 
On the Define Chassis dialog box, add all of the appropriate 
modules to that chassis to match the actual hardware allocated on 
your network. When complete, click OK. 

Repeat for each adapter module on your ControlNet network. 

1. In RSNetWorx for ControlNet, define the local rack information and 
insert the connections needed by the PLC-5C for ControlNet 
communication. Complete the following: 

a. In the network configuration, click a PLC-5C processor and then 
select Device > Scanlist Configuration. RSNetWorx for 
ControlNet launches an instance of the Scanlist Configuration Tool 
and displays the scanlist for the selected PLC-5C processor. 

Define the network layout 

Define the local rack information and 
insert connections 
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The PLC-5C you are currently configuring is highlighted in green. 

b. Click Device > I/O File Allocation. Specify your local rack 
information, then click OK. 

c. Click the device that you want to insert a connection to, then select 
Connection > Insert. On the Connection Properties dialog, specify 
all of the ControlNet configuration properties associated with that 
connection. When complete, click OK. 

Repeat for each device that you want to connect to on your 
ControlNet network. 

Tip: You can insert default connections to all of the devices on the ControlNet network 
or a selected set of devices on the ControlNet network. Select Connection > Auto 
Insert > All Devices to search all of the devices in the configuration and insert a 
pending connection entry. Select Connection > Auto Address > All Entries to 
allow the software to select the next available, unconfigured address and define 
the ControlNet specific files (for example, status, configuration, data input, and 
data output) needed for each connection. 

2. Repeat step 1 of this section for each PLC-5C on your ControlNet 
network. 

Tip: Keep in mind that a separate instance of the Scanlist Configuration Tool will be 
launched for each PLC-5C that you are actively editing on your ControlNet network. 

3. In RSNetWorx for ControlNet, select File > Save to save your work to 
the ControlNet configuration file (*.xc). You will associate individual 
RSLogix 5 project files (.rsp) to this file in the following sections. 

When complete, minimize each instance of the Scanlist Configuration 
Tool. Then minimize RSNetWorx for ControlNet. 

1. In RSLogix 5, create a new project for a PLC-5C processor and 
associate the project to the configuration file (*.xc) created in 
RSNetWorx for ControlNet. Complete the following: 

a. Start RSLogix 5. 

b. Open a new project file by selecting File > New. On the Select 
Processor Type dialog, specify the correct platform (ControlNet), 
PLC-5C processor (including series and revision), processor name, 
communication driver, and node number for a PLC-5C processor 
on your ControlNet network. Click OK. 

Associate an RSLogix 5 project file 
(*.rsp) with each PLC-5C node in the 
ControlNet configuration file (*.xc) 
and specify module configuration 
information 
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Tip: To work with a ControlNet network, you must specify one of the PLC-5C processors 
that are followed by 1.5 suffix (for example, PLC-5/40C 1.5). 

c. On the Select ControlNet Project dialog, browse your computer to 
find the ControlNet configuration file (*.xc) that you created in 
steps 1 and 2 of the Define the local rack information and insert 
connections on page 50 section. In addition, specify the node 
address where the specified PLC-5C processor resides on your 
ControlNet network, and then click OK. 

2. Configure each module and store the configuration data in the 
processor’s data table. To define these locations in RSLogix 5, 
complete the following: 

a. In the Project tree control, select the I/O Configuration icon. Click 
the right mouse button and select Open. On the I/O Configuration - 
Chassis Table dialog, all of the devices that this processor 
communicates with and associated I/O mapping information are 
displayed. 

b. Select the chassis that contains the module that you want to 
configure on the ControlNet network. Click the right mouse button 
and select Display Chassis. Each of the modules that this PLC-5C 
communicates with in that chassis are automatically added by 
RSNetWorx for ControlNet and displayed. 

c. Select the module type in that chassis that you want to configure. 
Click the right mouse button and select Display Module. On the 
Module Configuration dialog for the selected module, configure 
the module for your application. When complete, click Accept 
Edits, and then click Close. Close all of the associated dialogs. 

Repeat for each module in that chassis (if applicable). 

3. Enter the appropriate ladder logic for the PLC-5C processor. 

4. Save the RSLogix 5 project file (*.rsp) for this PLC-5C processor. At 
this point, the changes are committed to the specified RSLogix 5 
project file and all pending edit information is included in the 
associated .xc file. Close the RSLogix 5 project file. 

5. Repeat steps 1 through 4 of this section for each PLC-5C processor on 
your ControlNet network. 

Tip: Be sure to specify a unique ControlNet node number for each PLC-5C processor on 
your ControlNet network. 

When complete, minimize RSLogix 5. 
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1. In RSNetWorx for ControlNet, integrate the changes made in RSLogix 
5 for each PLC-5C on the network to the configuration file (*.xc) 
created in the Define the network layout on page 50 and Define the 
local rack information and insert connections on page 50 sections. 
Complete the following: 

a. Maximize RSNetWorx for ControlNet and select the Edits Enabled 
checkbox. All changes made in RSLogix 5 are automatically 
included as pending edits. 

Tip: In each instance of the Scanlist Configuration Tool, you can review the changes 
made to the modules in RSLogix 5. These changes appear in blue text (pending 
edits). 

b. In RSNetWorx for ControlNet (or any instance of the Scanlist 
Configuration Tool), select File > Save to incorporate all of the 
pending RSLogix 5 changes into the associated .xc file. On the 
Save configuration dialog, select the correct save option and click 
OK. 

c. Minimize each instance of the Scanlist Configuration Tool. 

Your system configuration is now complete. 

1. Attach to the online ControlNet network and download the integrated 
configuration file (*.xc). Complete the following: 

a. Select Network > Online. On the Network Browse dialog, select 
the ControlNet network to which you want to download the 
integrated configuration file (*.xc). Click OK. 

Tip: If the Online/Offline Mismatch dialog appears, specify that you want to use the 
offline data and download it to the network. Click OK. 

If the Online/Offline Mismatch dialog does not appear, select 
Network > Download. 

b. Close RSNetWorx for ControlNet. Each instance of the Scanlist 
Configuration Tool closes automatically. 

1. In RSLogix 5, open each project file (*.rsp) that was created for each 
PLC-5C node on your network. Complete the following: 

a. Select Comms > System Comms. On the Communications dialog, 
select the appropriate node, and then click Download. You are 
prompted to proceed with the download; click Yes. 

b. You are prompted to keep the existing online configuration; click 
Yes. You are prompted to continue with the download; click Yes. 

Integrate RSLogix 5 edits 

Download the ControlNet 
configuration file (*.xc) that contains 
the PLC-5C scanlist 

Download and synchronize the 
RSLogix 5 project file (*.rsp) with the 
online PLC-5C 
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c. On the Save Program As dialog, you are prompted to save the 
RSLogix 5 file; click Save. You are then prompted to go online; 
click Yes. 

d. Select Remote Run mode. 

2. Repeat for each RSLogix 5 project file (*.rsp). When complete, 
RSLogix 5 and RSNetWorx for ControlNet are synchronized. 

For more information about the integration of RSLogix 5 and RSNetWorx 
for ControlNet, contact Rockwell Software Technical Support. 

To quickly and effectively use RSNetWorx for ControlNet and RSLogix 5 in 
the offline mode when Allen-Bradley remote I/O (RIO) is a consideration, 
and then download that information to your online network, perform the 
following steps: 

Tip: These steps assume that you have configured a communication driver with RSLinx 
Classic for communication to your ControlNet network. 

 Open the ControlNet configuration file (*.xc) and define the network 
layout 

 Define the local rack information 

 Associate each PLC-5C to the ControlNet configuration file (*.xc) and 
define the remote I/O 

 Insert connections 

 Specify module configuration information 

 Integrate RSLogix 5 edits 

 Download the ControlNet configuration file (*.xc) that contains the 
PLC-5C scanlist 

 Download and synchronize the RSLogix 5 project file (*.rsp) with the 
online PLC-5C 

1. In RSNetWorx for ControlNet, define the hardware layout of your 
ControlNet network. Complete the following: 

a. Start RSNetWorx for ControlNet and click the Edits Enabled 
checkbox. 

Offline with Allen-Bradley 
remote I/O (RIO) usage 

Open the ControlNet configuration 
file (*.xc) and define the network 
layout 
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b. In the Hardware view, select one of the devices on your 
ControlNet network (for example, PLC-5C or adapter module) and 
drag it to the network configuration area (either the Graph or 
Spreadsheet view). RSNetWorx for ControlNet automatically 
assigns the next available node number to the device; if it is not 
acceptable for your application, change the node number 
accordingly. 

Repeat for each device on your ControlNet network. 

c. Click an adapter module in the network configuration and specify 
the contents of the chassis by selecting Device > Define Chassis. 
On the Define Chassis dialog box, add all of the appropriate 
modules to that chassis to match the actual hardware allocated on 
your network. When complete, click OK. 

Repeat for each adapter module on your ControlNet network. 

1. In RSNetWorx for ControlNet, define the local rack information 
needed by the PLC-5C for ControlNet communication. Complete the 
following: 

a. In the network configuration, click a PLC-5C processor and then 
select Device > Scanlist Configuration. RSNetWorx for 
ControlNet launches an instance of the Scanlist Configuration Tool 
and displays the scanlist for the selected PLC-5C processor. 

The PLC-5C you are currently configuring is highlighted in green. 
In addition, the name of the PLC-5C is also displayed in the title 
bar. 

b. Click Device > I/O File Allocation. Specify your local rack 
information, then click OK. 

c. Select File > Save to save your work to a ControlNet configuration 
file (*.xc). You will associate individual RSLogix 5 project files 
(*.rsp) to this file in the following sections. 

When complete, close the Scanlist Configuration Tool. 

2. Repeat step 1 of this section for each PLC-5C on your ControlNet 
network, saving your changes to the same ControlNet configuration 
file (*.xc) created in step 1c. 

When complete, minimize RSNetWorx for ControlNet. 

Define the local rack information 
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1. In RSLogix 5, create a new project for a PLC-5C processor and 
associate the project to the ControlNet configuration file (*.xc) 
generated in step 1 of the Define the local rack information on page 55 
section. Complete the following: 

a. Start RSLogix 5. 

b. Open a new project file by selecting File > New. On the Select 
Processor Type dialog, specify the correct platform (ControlNet), 
PLC-5C processor (including series and revision), processor name, 
communication driver, and node number for a PLC-5C processor 
on your ControlNet network. Click OK. 

Tip: To work with a ControlNet network, you must specify one of the PLC-5C processors 
that are followed by 1.5 suffix (for example, PLC-5/40C 1.5). 

c. On the Select ControlNet Project dialog, click Browse to find the 
location where your ControlNet configuration files (*.xc) reside. 
On the Open dialog, find the appropriate directory location on your 
computer, and then select the name for the ControlNet 
configuration file created in step 1c of the Define the local rack 
information on page 55 section. When complete, click Open. 

When you return to the Select ControlNet Project dialog, specify 
the node address where the specified PLC-5C processor resides on 
your ControlNet network, and then click OK. 

2. Configure the remote I/O data table settings for your ControlNet 
network. Complete the following: 

a. In the Project tree control, select the Channel Configuration icon. 
Click the right mouse button and select Open. 

b. Coordinate your remote I/O channel settings for your specific 
application. When complete, click Apply, and then close all 
associated dialogs. 

c. When complete, close the Edit Channel Properties dialog. 

3. Select File > Save to save your RSLogix 5 project file (*.rsp). Specify 
a name for your RSLogix 5 project file, and then click Save. All 
changes will also be associated to the ControlNet configuration file 
(*.xc) that you created in step 1 of this section. 

When complete, close the RSLogix 5 project file. 

4. Complete steps 1 through 3 of this section for each PLC-5C on your 
ControlNet network. Note that for each PLC-5C on your network, you 
will associate the same ControlNet configuration file (*.xc) specified in 
step 1c of the Define the local rack information on page 55 section. 

Associate each PLC-5C to the 
ControlNet configuration file (*.xc) 
and define the remote I/O 
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When complete, minimize RSLogix 5. 

1. In RSNetWorx for ControlNet, define the data table input, output, and 
integer file locations needed by the PLC-5C for ControlNet 
communication. To define these locations, complete the following: 

a. Maximize RSNetWorx for ControlNet and click the Edits Enabled 
checkbox. A separate instance of the Scanlist Configuration Tool 
will be launched for each PLC-5C that you are actively editing on 
your ControlNet network. 

Tip: When working offline, the number of scanners (for example, PLC-5C processors) 
that can be scheduled on a ControlNet network are dependent upon the particular 
operating system and the amount of RAM installed on the computer. For more 
information, see the capacity document. 

b. In the network configuration of RSNetWorx for ControlNet, click 
a PLC-5C processor and then select Device > Scanlist 
Configuration. RSNetWorx for ControlNet displays the instance 
of the Scanlist Configuration Tool that contains the scanlist for the 
selected PLC-5C processor. The PLC-5C you are currently 
configuring is highlighted in green. In addition, the PLC-5C is also 
displayed in the title bar. 

c. Click the device that you want to insert a connection to, then select 
Connection > Insert. On the Connection Properties dialog, specify 
all of the ControlNet configuration properties associated with that 
connection. When complete, click OK. 

Repeat for each device that you want to connect to on your 
ControlNet network. 

Tip: You can insert default connections to all of the devices on the ControlNet network 
or a selected set of devices on the ControlNet network. Select Connection > Auto 
Insert > All Devices to search all of the devices in the configuration and insert a 
pending connection entry. Select Connection > Auto Address > All Entries to 
allow the software to select the next available, unconfigured address and define 
the ControlNet specific files (for example, status, configuration, data input, and 
data output) needed for each connection. 

2. Repeat step 1 of this section for each PLC-5C on your ControlNet 
network. 

3. In RSNetWorx for ControlNet, select File > Save to save your work to 
the ControlNet configuration file (*.xc). 

When complete, minimize each instance of the Scanlist Configuration 
Tool. Then minimize RSNetWorx for ControlNet. 

1. In RSLogix 5, configure each module and store the configuration data 
in the processor’s data table. To define these locations in RSLogix 5, 

Insert connections 

Specify module configuration 
information 
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complete the following: 

a. Maximize RSLogix 5. 

b. Open the RSLogix 5 project file (*.rsp) for a PLC-5C processor. 

c. In the Project tree control, select the I/O Configuration icon. Click 
the right mouse button and select Open. On the I/O Configuration - 
Chassis Table dialog, all of the devices that this processor 
communicates with and associated I/O mapping information are 
displayed. 

d. Select the chassis that contains the module that you want to 
configure on the ControlNet network. Click the right mouse button 
and select Display Chassis. Each of the modules that this PLC-5C 
communicates with in that chassis are automatically added by 
RSNetWorx for ControlNet and displayed. 

Select the module type in that chassis that you want to configure. 
Click the right mouse button and select Display Module. On the 
Module Configuration dialog for the selected module, configure 
the module for your application. When complete, click Accept 
Edits, and then click Close. Close all of the associated dialogs. 
Repeat for each module in that chassis (if applicable). 

Tip: RSNetWorx for ControlNet will be displayed, signifying that changes have been 
made in RSLogix 5. Minimize RSNetWorx for ControlNet. 

2. Enter the appropriate ladder logic for the PLC-5C processor. 

3. Select File > Save to save the RSLogix 5 project file (*.rsp) for this 
PLC-5C processor. At this point, the changes are committed to the 
specified RSLogix 5 project file and all pending edit information is 
included in the associated .xc file. Close the RSLogix 5 project file. 

4. Repeat steps 1 through 3 of this section for each PLC-5C processor on 
your ControlNet network. 

When complete, minimize RSLogix 5. 

1. In RSNetWorx for ControlNet, integrate the changes made in RSLogix 
5 for each PLC-5C on the network to the ControlNet configuration file 
(*.xc) created in step 1c of the Define the local rack information on 
page 55 section. Complete the following: 

a. Maximize RSNetWorx for ControlNet and select the Edits Enabled 
checkbox. All changes made in RSLogix 5 are automatically 
included as pending edits. 

Integrate RSLogix 5 edits 
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Tip: In each instance of the Scanlist Configuration Tool, you can review the changes 
made to the modules in RSLogix 5. These changes appear in blue text (pending 
edits). 

b. In RSNetWorx for ControlNet (or any instance of the Scanlist 
Configuration Tool), select File > Save to incorporate all of the 
pending RSLogix 5 changes into the associated ControlNet 
configuration file (*.xc). On the Save configuration dialog, select 
the correct save option and click OK. 

c. Minimize each instance of the Scanlist Configuration Tool. 

Your system configuration is now complete. 

1. In RSNetWorx for ControlNet, attach to the online ControlNet 
network and download the integrated ControlNet configuration file 
(*.xc). Complete the following: 

a. Select Network > Online. On the Network Browse dialog, select 
the ControlNet network to which you want to download the 
integrated configuration file (*.xc). Click OK. 

Tip: If the Online/Offline Mismatch dialog appears, specify that you want to use the 
offline data and download it to the network. Click OK. 

If the Online/Offline Mismatch dialog does not appear, select 
Network > Download. 

b. Close RSNetWorx for ControlNet. Each instance of the Scanlist 
Configuration Tool closes automatically. 

1. In RSLogix 5, open each project file (*.rsp) that was created for each 
PLC-5C node on your network. Complete the following: 

a. Select Comms > System Comms. On the Communications dialog, 
select the appropriate node, and then click Download. You are 
prompted to proceed with the download; click Yes. 

b. You are prompted to keep the existing online configuration; click 
Yes. You are prompted to continue with the download; click Yes. 

c. On the Save Program As dialog, you are prompted to save the 
RSLogix 5 file; click Save. You are then prompted to go online; 
click Yes. 

d. Select Remote Run mode. 

2. Repeat for each RSLogix 5 project file (*.rsp). When complete, 
RSLogix 5 and RSNetWorx for ControlNet are synchronized. 

Download the ControlNet 
configuration file (*.xc) that contains 
the PLC-5C scanlist 

Download and synchronize the 
RSLogix 5 project file (*.rsp) with the 
online PLC-5C 
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For more information about the integration of RSLogix 5 and RSNetWorx 
for ControlNet, contact Rockwell Software Technical Support. 

To quickly and effectively use RSNetWorx for ControlNet and RSLogix 5 in 
the online mode when Allen-Bradley remote I/O (RIO) is a consideration, 
perform the following steps: 

Tip: These steps assume that you have configured a communication driver with RSLinx 
Classic for communication to your ControlNet network. 

 Open the ControlNet configuration file (*.xc) and define the network 
layout 

 Define the local rack information 

 Associate each PLC-5C to the ControlNet configuration file (*.xc) and 
define the remote I/O 

 Insert connections 

 Specify module configuration information 

 Integrate RSLogix 5 edits 

 Synchronize the RSLogix 5 project file (*.rsp) with the online PLC-5C 

1. In RSNetWorx for ControlNet, define the hardware layout of your 
ControlNet network. Complete the following: 

a. Start RSNetWorx for ControlNet and select Network > Online. 

b. On the Browse for Network dialog, select a communication path to 
your ControlNet network, and then click OK. Allow the entire 
browse operation to complete before proceeding. The entire 
network configuration is displayed. 

Tip: If the Online/Offline Mismatch dialog appears, choose the use the offline data 
(download) option, and then click OK. 

c. Click the Edits Enabled checkbox. 

1. In RSNetWorx for ControlNet, define the local rack information 
needed by the  
PLC-5C for ControlNet communication. Complete the following: 

a. In the network configuration, click a PLC-5C processor and then 
select Device > Scanlist Configuration. RSNetWorx for 
ControlNet launches an instance of the Scanlist Configuration Tool 
and displays the scanlist for the selected PLC-5C processor. The 
local rack information is automatically obtained for the selected 
PLC-5C processor. 

Online with Allen-Bradley 
remote I/O (RIO) usage 

Open the ControlNet configuration 
file (*.xc) and define the network 
layout 

Define the local rack information 
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The PLC-5C you are currently configuring is highlighted in green. 
In addition, the name of the PLC-5C is also displayed in the title 
bar. 

b. Select File > Save to save your work to a ControlNet configuration 
file (*.xc). You will associate individual RSLogix 5 project files 
(*.rsp) to this file in the following sections. 

When complete, close the Scanlist Configuration Tool. 

2. Repeat step 1 of this section for each PLC-5C on your ControlNet 
network, saving your changes to the same ControlNet configuration 
file (*.xc) created in step 1b. 

When complete, minimize RSNetWorx for ControlNet. 

1. In RSLogix 5, create a new project for a PLC-5C processor and 
associate the project to the ControlNet configuration file (*.xc) 
generated in step 1 of the Define the local rack information on page 60 
section. Complete the following: 

a. Start RSLogix 5, and then select Comms > Who ActiveGo 
Online. 

b. In the Communications dialog, select a PLC-5C processor node, 
and then click OK. 

c. On the Default Program Rename dialog, enter a name for the 
selected PLC-5C processor, and then click OK. The processor 
image is uploaded to the RSLogix 5 project file (*.rsp). 

Tip: If the PLC-5C already has a name, the Going to Online dialog is displayed. Click 
Create New File. 

d. In the Project tree control, select the Controller Properties icon. 
Click the right mouse button and select Open. On the Controller 
Properties dialog, click Browse to find the directory location 
where your ControlNet configuration files (*.xc) reside. On the 
Open dialog, find the appropriate directory location on your 
computer, and then select the name for the ControlNet 
configuration file created in step 1. 

When complete, click Open. 
When you return to the ControlNet Properties dialog, specify the 
node address where the specified PLC-5C processor resides on 
your ControlNet network, and then click OK. 

Associate each PLC-5C to the 
ControlNet configuration file (*.xc) 
and define the remote I/O 
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Tip: It is not necessary to enter a value for the ControlNet Source Link ID field. For more 
information on the ControlNet Source Link ID field, see the RSLogix 5 online help. 

2. Configure the remote I/O data table settings for your ControlNet 
network. Complete the following: 

a. In the Project tree control, select the Channel Configuration icon. 
Click the right mouse button and select Open. 

b. Coordinate your remote I/O channel settings for your specific 
application. When complete, click Apply, and then close all 
associated dialogs. 

c. When complete, close the Edit Channel Properties dialog. 

d. Select File > Save to save your RSLogix 5 project file (*.rsp). 
Specify a name for your RSLogix 5 project file, and then click 
Save. You are prompted to upload your changes; click Yes. At this 
point, the changes are committed to the specified RSLogix 5 
project file. In addition, all changes will also be associated to the 
ControlNet configuration file (*.xc) that you created in step 1. 

e. When complete, close the RSLogix 5 project file. 

3. Complete steps 1 through 3 for each PLC-5C on your ControlNet 
network. Note that for each PLC-5C on your network, you will 
associate the same ControlNet configuration file (*.xc) specified in 
step 1b of the Define the local rack information on page 60 section. 
When complete, minimize RSLogix 5. 

1. In RSNetWorx for ControlNet, define the connections needed by the 
PLC-5C for ControlNet communication. To define these connections, 
complete the following: 

a. Maximize RSNetWorx for ControlNet and click the Edits Enabled 
checkbox. A separate instance of the Scanlist Configuration Tool 
will be launched for each PLC-5C that you are actively editing on 
your ControlNet network. 

Tip: When working online, the number of scanners (for example, PLC-5C processors) 
that can be scheduled on a ControlNet network are dependent upon the particular 
communications device and operating system. For more information, see the 
capacity document. 

b. In the network configuration, click a PLC-5C processor and then 
select Device > Scanlist Configuration. RSNetWorx for 
ControlNet launches an instance of the Scanlist Configuration Tool 
and displays the scanlist for the selected PLC-5C processor. 

Insert connections 
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The PLC-5C you are currently configuring is highlighted in green. 
In addition, the name of the PLC-5C is also displayed in the title 
bar. 

2. Click the device that you want to insert a connection to, then select 
Connection > Insert. On the Connection Properties dialog, specify all 
of the ControlNet configuration properties associated with that 
connection. 

When complete, click OK. 

Repeat for each device that you want to connect to on your ControlNet 
network. 

Tip: You can insert default connections to all of the devices on the ControlNet network 
or a selected set of devices on the ControlNet network. Select Connection > Auto 
Insert > All Devices to search all of the devices in the configuration and insert a 
pending connection entry. Select Connection > Auto Address > All Entries to 
allow the software to select the next available, unconfigured address and define 
the ControlNet specific files (for example, status, configuration, data input, and 
data output) needed for each connection. 

3. Repeat step 2 of this section for each PLC-5C on your ControlNet 
network. 

Tip: Keep in mind that a separate instance of the Scanlist Configuration Tool will be 
launched for each PLC-5C that you are actively editing on your ControlNet network. 

4. In RSNetWorx for ControlNet, select File > Save to save your work to 
the ControlNet configuration file (*.xc). 

When complete, minimize each instance of the Scanlist Configuration 
Tool. Then minimize RSNetWorx for ControlNet. 

1. Configure each module and store the configuration data in the 
processor’s data table. To define these locations in RSLogix 5, 
complete the following: 

a. In RSLogix 5, open a RSLogix 5 project file (*.rsp) for a PLC-5C 
and select Comms > Go Online. 

b. On the Going to Online Programming State dialog, click Upload 
Logic, Merge with Existing Files Comments/Symbols Database. 
The processor image is uploaded to the RSLogix 5 project file 
(*rsp). 

c. In the Project tree control, select the I/O Configuration icon. Click 
the right mouse button and select Open. On the I/O Configuration - 
Chassis Table dialog, all of the devices that this processor 
communicates with and associated I/O mapping information are 
displayed. 

Specify module configuration 
information 
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d. Select the chassis that contains the module that you want to 
configure on the ControlNet network. Click the right mouse button 
and select Display Chassis. Each of the modules that this PLC-5C 
communicates with in that chassis are automatically added by 
RSNetWorx for ControlNet and displayed. 

e. Select the module type in that chassis that you want to configure. 
Click the right mouse button and select Display Module. On the 
Module Configuration dialog for the selected module, configure 
the module for your application. When complete, click Accept 
Edits, and then click Close. Close all of the associated dialogs. 

Repeat for each module in that chassis (if applicable). 

Tip: RSNetWorx for ControlNet will be displayed, signifying that changes have been 
made in RSLogix 5. Minimize RSNetWorx for ControlNet. 

2. Enter the appropriate ladder logic for the PLC-5C processor. 

3. Select File > Save to save the RSLogix 5 project file (*.rsp) for this 
PLC-5C processor. 

4. Select Comms > Download. You are prompted to keep existing 
changes; click Yes. At this point, the changes are committed to the 
specified RSLogix 5 project file and all pending edit information is 
included in the associated .xc file. Close the RSLogix 5 project file. 

5. Repeat steps 1 through 4 of this section for each PLC-5C processor on 
your ControlNet network. 

Tip: Be sure to specify a unique ControlNet node number for each PLC-5C processor on 
your ControlNet network. 

When complete, minimize RSLogix 5. 

1. In RSNetWorx for ControlNet, integrate the changes made in RSLogix 
5 to the ControlNet configuration file (*.xc) created in step 1 of the 
Define the local rack information on page 60 section for each PLC-5C 
on the network. Complete the following: 

a. Maximize RSNetWorx for ControlNet and select the Edits Enabled 
checkbox. All changes made in RSLogix 5 are automatically 
included as pending edits. 

Integrate RSLogix 5 edits 
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Tip: In each instance of the Scanlist Configuration Tool, you can review the changes 
made to the modules in RSLogix 5. These changes appear in blue text (pending 
edits). 

b. In RSNetWorx for ControlNet (or any instance of the Scanlist 
Configuration Tool), select File > Save to incorporate all of the 
pending RSLogix 5 changes into the associated ControlNet 
configuration file (*.xc). On the Save configuration dialog, select 
the correct save option and click OK. 

c. Close RSNetWorx for ControlNet. Notice that each instance of the 
Scanlist Configuration Tool closes automatically. 

Your system configuration is now complete. 

1. In RSLogix 5, open each project file (*.rsp) that was created for each 
PLC-5C node on your network. Complete the following: 

a. Open a RSLogix 5 project file (*.rsp). 

b. Select Comms > Upload to save the network configuration in the 
ControlNet configuration file (*.xc). Your offline network should 
match your online network. 

c. Select Comms > Go Online. 

d. Select Remote Run mode. 

2. Repeat for each RSLogix 5 project file (*.rsp). When complete, 
RSLogix 5 and RSNetWorx for ControlNet are synchronized. 

For more information about the integration of RSLogix 5 and RSNetWorx 
for ControlNet, contact Rockwell Software Technical Support. 

 

Synchronize the RSLogix 5 project file 
(*.rsp) with the online PLC-5C 
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Chapter 4 

Finding the information you need 

This chapter describes how to: 

 Use the online help 

 Access product manuals 

 Participate in Rockwell Automation training courses 

 Contact technical support 

RSNetWorx for ControlNet online help provides general overview 
information, comprehensive step-by-step procedures, and context-sensitive, 
dialog box control definitions for working with all of the features in the 
software. To view online help while running RSNetWorx for ControlNet: 

 choose Contents from the Help menu on the RSNetWorx for 
ControlNet main window 

 click Help on any RSNetWorx for ControlNet dialog box or property 
page 

 position the cursor over a control with which you want help and 
right-click 

 press F1 

 click the What’s This? icon located in the toolbar or in the upper right 
corner of dialog boxes, then click any control 

 

Using the online help 

Accessing help for a control or 
field 
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To display a definition for a control or a field, click the What’s This? icon in 
the upper right corner of the dialog box, drag the cursor to the selected area, 
and then click to display the definition. You can also right-click on a control 
to display the definition. In this example, the Current Maximum Scheduled 
Address was selected. 

 

The Message view, which appears in the bottom portion of the workspace, 
displays a log of messages. This view may contain informational, warning, 
and/or error messages. 

 

To troubleshoot a particular message, you can select the message and press 
the F1 key or right-click on the message and select Troubleshoot to access 
the online help. 

Accessing help for messages 
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For example, if you select the CNET:8116 message code shown here and 
press F1, the "This network is configured and there is no offline 
configuration" troubleshooting help topic displays. 

 

From the message view, you can also select a message and choose View > 
Messages > Troubleshoot to display online help for the message. You can 
also show,  clear, and/or clear and  hide messages by making the 
appropriate selection from the View > Messages command on the main 
menu. The copy menu item copies the selected message to the Windows 
clipboard so it can be pasted into other applications (for example, an e-mail 
message). 

To view a list of tasks related to the task-based topic, move to the What do 
you want to do? section at the bottom of the help window and select one of 
the listed tasks. The contents pane of the help window is updated, displaying 
a step by step procedure for completing the selected task.  

Finding step-by-step 
procedures 
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For example, from the Define or edit a chassis help topic, if you select 
Change a device’s slot position under the What do you want to do? section, 
the help topic that describes how to change a device’s slot position replaces 
the original help topic. Also, in the Change a device’s slot position help 
topic, How do I access the dialog? is a drop down navigational tip. 

 

Finding definitions 
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Within the RSNetWorx for ControlNet help, blue highlighted text with an 
underline indicates a pop-up definition or a link to a related topic. For 
example, in the Configure network parameters help topic, network update 
time, maximum scheduled address, maximum unscheduled address, media 
redundancy, and network name are pop-up definitions. 

 

You can gain immediate access to product documentation through the 
product manuals feature in RSNetWorx for DeviceNet. Product manuals 
include this Getting Results Guide, as well as many reference guides, in an 
electronic book format. Select Help > Product Manuals to access this 
documentation. 

 

One of the best ways to increase your proficiency at using Rockwell 
Software products is to attend a Rockwell Automation training program. Our 
training programs can help you master the basics and show you how to 
unleash the full potential of our software. 

Accessing the Product 
Manuals 

Training 
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We offer a wide range of training programs, from regularly scheduled classes 
conducted at Rockwell Software facilities, to custom-tailored classes 
conducted at your enterprise. The size of each class is kept small 
intentionally to maximize student engagement. 

If you would like more information about our training programs, visit the 
Rockwell Software website or contact the Rockwell Automation Training 
Coordinator. Our website address and telephone numbers appear on the 
inside front cover of this document. 

Tip: For more information on Rockwell Automation training, go to the Training Services 
website: 
http://www.rockwellautomation.com/global/products/training/overview.page?  

 

If you cannot find answers to your questions in the Getting Results with 
RSNetWorx for ControlNet guide, the online help, or the Online Books 
documentation, you can call Rockwell Software Technical Support at the 
numbers listed on the inside front cover of this guide. You can also access 
the Rockwell Software Online Support Library and receive information about 
Autofax Product Information System from the website listed on the inside 
front cover of this guide. 

When you call, you should be at your computer and prepared to give the 
following information: 

 product serial number and product version number 

 The product serial numbers and version number can be found in the 
software by selecting Help > About RSNetWorx 

 hardware you are using 

 operating system plus service packs, and version of Internet Explorer 
(if any) installed 

 exact wording of any errors or messages that appeared on your screen 

 description of what happened and what you were doing when the 
problem occurred 

 description of how you attempted to solve the problem 

Tip: For more information on Rockwell Software training, go to the Training Services 
website: 
http://www.rockwellautomation.com/global/products/training/overview.page?  

 

 

Technical support 

When you call 

http://www.rockwellautomation.com/global/products/training/overview.page?
http://www.rockwellautomation.com/global/products/training/overview.page?
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Appendix A 

Activation 

RSNetWorx for ControlNet only supports FactoryTalk activation. If you are 
a new user, you will need to activate your software using FactoryTalk 
Activation. 

RSNetWorx for ControlNet supports the following types of activation: 

Node-locked activation 

This type of activation can be either locked to a particular piece of hardware, 
such as an EtherNet card or a hard disk of a stand-alone computer, or to a 
hardware dongle. Depending upon the kind of device (stand-alone computer 
or hardware dongle) you want to activate, you can purchase either 

 Local "node-locked" activation: This kind of activation activates 
software only on a single computer. If the activation file is copied to 
another computer, the software will not run on that other computer, or 

 Mobile "node-locked" activation: This kind of activation is locked to 
hardware dongle. A dongle is a security or copy protection device that 
must be connected to the computer while the program runs. The 
activation files can be copied to multiple computers, but the software 
activates only on the computer where the dongle is connected. 

Concurrent activation 

This type of activation allows multiple computers across a network to use 
Rockwell Software products at the same time. There are two kinds of 
concurrent activations: 

 Floating activations: activations that "float" from an activation server 
to any computer that needs them. 

 Borrowed activations: activations that are retrieved from a server for a 
specific period of time before expiring and returning automatically to 
the pool of available activations on the server. 

For more information about FactoryTalk Activation, refer to the FactoryTalk 
Activation Manager help. 

You can activate your copy of RSNetWorx on the Software Activation 
dialog box towards the end of installation. If you skipped the activation 
during installation, activate RSNetWorx using the FactoryTalk Activation 
Manager installed during the installation process. 

Activate RSNetWorx with 
FactoryTalk Activation 

How to activate RSNetWorx 
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For help with FactoryTalk Activation at any point, you can click: 

 the Help button in FactoryTalk Activation Manager 

 the Help link on the Rockwell Software Activation website: 
https://activate.rockwellautomation.com/  

 View How to Activate Rockwell Software Products on the Required 
Steps of the Install program 

If you cannot connect to the Internet, call Technical Support for help creating 
an activation file from an e-mail or a fax. 

Phone: 440-646-3434 in North America. Outside of North America, call your 
local support organization. 

In RSNetWorx for ControlNet v9.00.00 (CPR 9 Service Release 1) and later, 
the software supports a seven day activation grace period when a valid 
activation is not found. During grace period: 

 If RSNetWorx is started and an activation key is not present, the 
software shall enter grace period and run with full functionality. 

 Once RSNetWorx has entered grace period, the software shall check 
for an activation key every four hours. If the activation is not found, a 
message will be generated to FactoryTalk Diagnostics. 

 RSNetWorx can be started an unlimited number of times while in 
grace period and be able to run with full functionality. If the grace 
period ends and a valid activation has not been found, RSNetWorx 
shall run in Demo mode. 

 While RSNetWorx is running, the software cannot change modes. 
RSNetWorx can only change to Demo mode when the software is 
restarted and/or grace period has already expired. 

Tip: If RSNetWorx is unable to successfully obtain valid activations (for example, a 
network failure occurs), the software will attempt run in grace period for up to 
seven days. 

 

To avoid damaging your activation files, do not perform the following 
operations with activation files on the hard drive. 

 Restore from backup 

 Upgrade the operating system 

 Compress or uncompress the hard drive 

Defragmentation utilities will not harm activation files. 

Following are some common problems that people encounter with activation 

Finding more information 
about FactoryTalk Activation 

Grace period 

Protecting your activation files 

Some common questions 

https://activate.rockwellautomation.com/
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and their solutions. 

If you have lost the activation because the activation file is damaged, you 
need to reset activation. Follow the Reset Codes instructions on the 
Rockwell Software Technical Support web page, or call the technical support 
telephone number. The web page and telephone number are both listed on the 
inside front cover of this guide. 

No. Deleting the program files does not delete your activation. The 
activation files are not stored in the program directory; they are located in the 
root directory. Your activation files will not be lost unless you format the 
hard drive, tamper with hidden files in the root directory, or perform certain 
other hard drive operations (refer to the "Protecting your activation files" 
section in this chapter for more information). 

To get the software running again, simply reinstall the software, but do not 
move the activation when given the opportunity. 

 

My activation files were damaged. 
What should I do? 

I accidentally deleted the software 
directory on my hard drive. Do I need 
to call Rockwell Software for 
replacement activation files? 
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Appendix B 

Security 

FactoryTalk Security™ is intended to improve the security of your 
automation system by limiting access to those with a legitimate need. 
FactoryTalk Security authenticates user identities and authorizes user 
requests to access a FactoryTalk-enabled system. These security services are 
fully integrated into the FactoryTalk Directory and are included as part of the 
FactoryTalk Services Platform that installs with many products. 

For more information on how to use security services, refer to FactoryTalk 
Security’s Online help. 

RSNetWorx supports FactoryTalk Security. FactoryTalk Security is intended 
to improve the security of your automation system by limiting access to 
those with a legitimate need. FactoryTalk Security authenticates the 
identities of users and authorizes user requests to access a 
FactoryTalk-enabled system against a set of defined user accounts and access 
privileges held in the FactoryTalk Directory. For more information on 
FactoryTalk Security, refer to the "About FactoryTalk Security" topic in 
RSNetWorx for ControlNet Online Help. 

Follow the steps below to set up security in RSNetWorx: 

How do I set up security in 
RSNetWorx? 
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1. During RSNetWorx’s installation, you will see the RSNetworx 
Security Configuration Selection page. On this page, select the 
Enable FactoryTalk® Security option. And then select the 
FactoryTalk Directory (Network or Local) that will be used to 
authenticate and authorize user access. 

 

2. Click Install to continue the RSNetWorx installation. 

3. Follow the screen instructions to complete the installation. 

RSNetWorx implements FactoryTalk Security through three securable 
actions: Access, Modify, and Go Online. These securable actions let you 
restrict user access to actions, such as opening a project file, creating a new 
project file, making changes to a project file, uploading or downloading to a 
device, browsing to a device from the network, viewing the properties of a 
device, etc., in RSNetWorx. 

What can I secure in 
RSNetWorx? 
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Securable action Description 

Access The Access securable action allows you to perform actions such as opening an 
offline project file for viewing, viewing the properties of a device, etc. 

Modify The Modify securable action allows you to perform actions such as creating a 
project file, making changes to a project file, saving any pending edits, etc. 

To modify a project file, you need both Access (to open the file) and Modify (to make changes) securable actions. 

Go Online The Go Online securable action allows you to download information saved in a 
project file or upload information into a project file, as well as browse to a device 
on the network. 

 To download information saved in an existing project file, you need Access (to open the file), Go Online (to go online to 
prepare to download), and Modify (to download) securable actions. 

 To upload information into an existing project file, you need Access (to open the file), Go Online (to go online to 
prepare to upload), and Modify (to upload) securable actions. 

 To upload information into a new project file, you need Go Online (to go online to upload) securable action. 

To allow or deny user access to one or more of the above securable actions, 
you will need to: 

1. Start FactoryTalk Administration Console from Start > Programs > 
Rockwell Software > FactoryTalk Administration Console. You 
will see the Log On to FactoryTalk screen, as shown below. 

 

2. Enter your username and password, and select the directory you want 
to log on to. (The username and password were set when you set up an 
account during FactoryTalk Directory configuration.) 

Tips for choosing a directory: 

 Click Network to access Network (also called Distributed) 
applications on the Network Directory Server. 

 Click Local to access Local (also called Stand-alone) applications 
on the Local Directory. Local applications are always located on 
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your local computer. You cannot access local applications 
remotely. 

 If you cannot log on to a particular directory on your computer, it 
may be because it has not yet been configured. For more 
information, refer to the Right FactoryTalk Directory is not 
configured on this computer topic in FactoryTalk help. You can 
launch FactoryTalk Help from FactoryTalk Administration 
Console. 

3. In FactoryTalk Administration Console, click on the RSNetWorx 
folder (located under System > Policies > Product Policies), to 
expand it. You will see the Feature Security file. 

4. Double-click the Feature Security file to launch the Feature Security 
Properties dialog box. 

 

5. In the Feature Security Properties dialog box, click the securable action 
you want to grant the user access to. 

6. In the Configure Securable Action dialog box, from the list of users, 
select the user you want to grant access to, and click Add. 

Tip: For more information on FactoryTalk and FactoryTalk Security, refer to RSNetWorx 
for ControlNet Online Help. 
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Appendix C 

Use unattended installation 

The unattended installation is an automated installation method that you can 
use to install RSNetWorx. You can typically use the unattended installation 
during large-scale rollouts when it might be too slow and costly to have 
administrators or technicians interactively install the RSNetWorx software 
on individual computers. 

In the unattended installation, you enter a specified command line with 
multiple parameters. During the installation process, instead of prompting 
you for installation and configuration information interactively, the process 
follows the parameters you specified in the command lines. 

For detailed description about each parameter, see Parameters on page 82. 
You can also type Setup /? in the Command Prompt window, and press 
Enter to view the help information of all parameters and examples. 

To install RSNetWorx in the unattended mode, follow the steps below. The 
steps may vary slightly. Follow the on-screen instructions that apply to your 
operating system. 

1. Close all open Windows programs. 

2. Open the Command Prompt window. 

3. In the Command Prompt window, navigate to D:, where D: is the 
drive containing the RSNetWorx installation DVD or installation 
package, and press Enter. 

Tip: The User Account Control dialog box may show after you press Enter, click Yes 
to continue. The unattended installation requires the administrator permission. 

4. Type a command line with the following syntax: 

Setup {/Q | /QS} 

/IAcceptAllLicenseTerms 

[/AutoRestart] 

[/SetupLanguage=language] 

[/ProductLanguage=product_language] 

[/InstallLocation=location] 

[/SerialNumber=serial_number] 

[/ProductKey=product_key] 

[/Version=product_version] 

Perform unattended 
installation 
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5. Press Enter. The installation process starts with the parameters you 
specified. 

The parameters and values are not case sensitive. If the value includes 
spaces, you need to enclose it in quotation marks (" "). 

If your installation package is Personalized Edition, the following parameters 
will be ignored during installation: 

 /SerialNumber 

 /ProductKey 

/Q 

Required if /QS or /Record is not specified. 

Installs the product in the silent mode without any user interface. 

/QS 

Required if /Q or /Record is not specified. 

Installs the product in the unattended mode without user interaction 
during installation, and shows the progress, errors, or complete 
messages on the user interface. 

/IAcceptAllLicenseTerms 

Required. Specified that you read and acknowledge all license 
agreements, and agree to continue the installation. 

/AutoRestart 

Optional. If specified, the computer will be restarted automatically 
after the installation if a restart is required to complete the installation. 

The parameter is ignored if a restart is not required. 

/SetupLanguage=setup_language 

Optional. Specifies which language will be displayed during the 
installation process. The value must be the one of ENU, CHS, DEU, 
ESP, FRA, ITA, JPN, KOR, or PTB. 

If it is omitted or if the specified language is not available, the default 
language is the user or system user interface language. 

/Record 

Optional. Records the installation options chosen to a recoding file. 

Parameters 
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/Playback 

Optional. Plays back a recording file to specify the installation options. 

/ProductLanguage=product_language 

Optional. Specifies which language of components will be installed. 
The value must be the one of ENU, CHS, DEU, ESP, FRA, ITA, 
JPN, KOR, or PTB. 

If it is omitted or if the specified language is not available, the default 
language is the same as SetupLanguage. 

/InstallLocation=location 

Optional. Specifies the installation location. 

If omitted, the default location is "C:\Program Files (x86)\Rockwell 
Software" (64-bit) or "C:\Program Files\Rockwell Software" (32-bit). 

/SerialNumber=serial_number 

Optional. Specifies the serial number that is required if you want to get 
activation keys during installation. 

/ProductKey=product_key 

Optional. Specifies the product key that is required if you want to get 
activation keys during installation. 

/Version=product_version 

Optional. Specifies the version corresponding to the product version 
that the SerialNumber and ProductKey are able to activate if you 
want to get activation keys during the installation. 

If omitted, the installer uses a default version which is the most recent 
product version available when retrieving the activation. 

The following examples show how to use the commands during the 
unattended installation. 

Example 1: 

Setup.exe /Q /IAcceptAllLicenseTerms 

means: 

 The installation uses the default settings during the installation process. 

Example 2: 

Examples 
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Setup.exe /QS /IAcceptAllLicenseTerms /AutoRestart 
/SetupLanguage=CHS /SerialNumber=0123456789 
/ProductKey=ABCDE-FGHIJ /Version=27.00.00 

means: 

 During the installation, the displayed language is Chinese. 

 The setup will get activation keys for RSNetWorx version 27.00.00 
during installation if the serial number 0123456789 and product key 
ABCDE-FGHIJ are valid. 

 After the installation, if a restart is required, the computer will be 
restarted automatically. 
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Glossary 

Active keeper — The active keeper is the node responsible for sending a 
periodic keeper broadcast on a ControlNet network and responding to 
requests for scanner signatures from any other nodes with scheduled 
connections on that network. The periodic keeper broadcast sent by the 
active keeper is a transparent scheduled message containing information 
about: 

 which keeper should be active 

 the overall network signature 

 any pending network change operations and network management 
resources 

All networks must have an active keeper to change the ControlNet network 
or start scheduled connections. After joining the network, any new node with 
scheduled connections will communicate with the active keeper to verify 
scanner signatures for the ControlNet configuration. If the scanner signatures 
are compatible, the node can join the network and scheduled connections 
begin. 

If more than one keeper capable node exists on the network, only one of 
those nodes can be the active keeper. For more information, see single keeper 
and multi-keeper. 

Activation file — A hidden, read-only, system file that "activates" a 
Rockwell Software product. The software will run only if your system can 
find the correct activation file. 

Activation key — Activation files contain a database of activation keys. 
Each key is particular to a certain product and must be accessible on a local 
or remote drive for that product to run. 

Actual packet interval — The actual packet interval (API) value is based on 
the NUI, and is always less than or equal to the RPI. The API value is the 
largest binary multiple (1, 2, 4, 8, 16, 32, 64, or 128) of the NUT, whose 
value is less than or equal to the RPI. 

Average scheduled bandwidth — Displays the percentage of average 
scheduled bandwidth, determined by averaging the percent of the NUT used 
for scheduled communication over (128) network update intervals for the 
configuration. 

Configuration file — The configuration file is a user-specified integer 
data-table file, or group of contiguous integer data-table files, that are limited 
only by available memory. This file stores configuration information for each 
of the connection entries that allow it, including all analog entries. If you 
specify a configuration file for a connection entry, the contents of the data 
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table address is sent to the device each time a connection is established. The 
configuration file is only applicable to the PLC-5C processor. 

Tip: You can specify and/or change a configuration file in the File Settings view 
available in the Scanlist Configuration Tool. 

Connection — An open, logically binding communication path between two 
devices on a ControlNet network. Connections can be either point to point or 
multicast connection. 

Connection ID — An identifier assigned to a particular connection between 
producers and consumers that specifies select application information. 

Connection type — The connection type indicates the data ownership of a 
node. It defines the rule for how the connection entry controls outputs to the 
rack, module, or device. The following are standard connection types: 

 Exclusive Owner - specifies an independent connection where a single 
device controls the output states in the target device. If you have an 
existing Exclusive Owner connection to a target device, you cannot 
specify another Exclusive Owner or Redundant connection to that 
same target device. 

Tip: For 1771 module connections, an Exclusive Owner rack connection must exist prior 
to this connection succeeding. Also, only a PLC-5C processor with an Exclusive 
Owner connection to the adapter can have Exclusive Owner module connections. 

 Input Only - specifies an independent connection where a device 
receives inputs from the target device and sends configuration data to 
the network. An Input Only connection does not send outputs; it only 
receives inputs. You can specify multiple Input Only connections to 
the target device from different originators. 

 Listen Only - specifies a dependent connection where a device receives  
inputs from the target device, but does not send configuration data with 
the network. A Listen Only connection only functions properly when 
another non-Listen Only connection exists to the same target device. A 
Listen Only connection does not send outputs; it only receives inputs. 
You can specify multiple Listen Only connections to the target device 
from different originators. 

Tip: All Listen Only connections will be terminated when all non-Listen Only 
connections are terminated. 

 Redundant - specifies an independent connection where both a primary 
and secondary device share control of outputs and send configuration 
data to the network. If you have an existing Redundant connection to a 
target device, you can specify another Redundant connection to that 
same target device, but cannot specify an Exclusive Owner connection. 

Tip: This connection type is used with a ControlNet PLC-5 Hot Backup system. 

Consumer — A node that receives data from a producer on a ControlNet 
link. 
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ControlNet network — An industrial automation network sponsored by 
ControlNet International. 

Data input file (DIF) — 

PLC-5C processor 

The data input file is a user-specified integer data-table file or group of 
contiguous integer data-table files (up to four). PLC-5C processors use this 
file to share non-discrete input data and scheduled peer-to-peer input data 
over the ControlNet network. The maximum number of words that can exist 
in the data input file is processor dependent. 

Processor Word maximum Files 

5/20C 2000 2 

5/40C 3000 3 

5/60C, 5/80C 4000 4 

For example, if you specify a Data Input File of N34 and a Data Input File 
Size of 4000 words, RSNetWorx for ControlNet will automatically create 
integer files N34, N35, N36, and N37, all 1000 words long. 

1747 Scanner 

The M1 file is a module input file for the 1747 SCNR. M1 files are most 
appropriately used for non-critical I/O data transfers. There is no image for 
these files in the processor memory. 

You can access ControlNet data located in M1 files using the COP(copy) 
instruction in your ladder program. The maximum data length you can 
transfer with the COP instruction is 128 words. The following explains the 
addressing format of M1 files: 

Mf:e.s 

M=module 

f=file type (1) 

e=slot (1-30) 

s=word (3 to max. supplied by module) 

The maximum number of words that can be supplied by the 1747-SCNR is 
255. 

Data output file (DOF) — 

PLC-5C processor 
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The data output file is a user-specified integer data-table file. PLC-5C 
processors use this file to share non-discrete output data and scheduled 
peer-to-peer output data over the ControlNet network. The maximum number 
of words that can exist in the data output file is processor dependent. 

Processor Word maximum Files 

5/20C 2000 2 

5/40C 3000 3 

5/60C, 5/80C 4000 4 

For example, if you specify a Data Output File of N30 and a Data Input File 
Size of 4000 words, RSNetWorx for ControlNet will automatically create 
integer files N30, N31, N32, and N33, all 1000 words long. 

1747 Scanner 

The M0 file is a module output file for the 1747 SCNR. M0 files are most 
appropriately used for non-critical I/O data transfers. There is no image for 
these files in the processor memory. 

During the processor scan, M0 data can be changed by the processor 
according to ladder diagram instructions addressing the M0 files. You can 
access ControlNet data located in M0 files using the COP(copy) instruction 
in your ladder program. The maximum data length you can transfer with the 
COP instruction is 128 words. The following explains the addressing format 
of M0 files: 

Mf:e.s 

M=module 

f=file type (0) 

e=slot (1-30) 

s=word (3 to max. supplied by module) 

The maximum number of words that can be supplied by the 1747-SCNR is 
255. 

Discrete input (output) data — The data coming from a rack (chassis) 
connection. Typically, it is an array of bits, each one representing a discrete 
(single) field wiring point. 

Diagnostic file — The diagnostic file is a user-specified integer data-table 
file starting at word zero. This file stores the PLC-5C processor diagnostic 
counters for the ControlNet channel. 
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If you are using this PLC-5C processor: The diagnostic file can be: 

Series F, Revision A or later 63 words 

Series E, Revision D or later 63 words 

Series D, Revision E or later 63 words 

Series C, Revision N or later 63 words 

Series E, Revision C or earlier 40 words 

Series D, Revision D or earlier 40 words 

Series C, Revision M or earlier 40 words 

 

Tip: Use of this file is optional. Defining it results in additional traffic on the ControlNet 
network. Refer to the ControlNet PLC-5 Programmable Controllers User Manual, 
Phase 1.5 (publication number 1785-6.5.22) for specification information. 

You can specify and/or change a diagnostic file in the File Settings view 
available in the Scanlist Configuration Tool. 

FactoryTalk is a manufacturing information platform that integrates 
plant-wide control systems and connects the enterprise with the production 
facility. 

The FactoryTalk Automation Platform: 

 provides common services (such as diagnostic messages and access to 
real-time data) and shares plant resources (such as tags and graphic 
displays) throughout a production facility 

 allows defining plant-floor resources once, and then allows 
simultaneous access to those resources across product boundaries 

 supports centralized security services 

FactoryTalk Administration Console — Part of the FactoryTalk 
Automation Platform, FactoryTalk Administration Console is an optional, 
stand-alone tool that allows you to: 

 Create and configure application, area, and data server elements in the 
FactoryTalk Directory. 

 Back up and restore an entire directory or an individual application. 

 Set up redundancy for OPC data servers. 

 Configure client computers to recognize the location of a FactoryTalk 
Directory Server computer. 

 Configure options for routing and logging diagnostic messages. 

 View system-wide diagnostic messages. 

 Configure system-wide policy settings. 
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 Secure your FactoryTalk-enabled system with FactoryTalk Security™ 
services. 

Run FactoryTalk Administration Console from the Windows Start menu: 
Start > Programs > Rockwell Software > FactoryTalk Administration 
Console. 

FactoryTalk Directory — FactoryTalk Directory provides a central lookup 
service for software products participating in a FactoryTalk-enabled 
automation system. 

The FactoryTalk Automation Platform includes two separate directories: a 
Local Directory and a Network Directory. Either directory, or both 
directories, can be configured on the same computer. Project information, 
including security settings, cannot be shared between a Local Directory and 
Network Directory, even if both directories are configured on the same 
computer. Create and configure application, area, and data server elements in 
the FactoryTalk Directory. 

 Local Directory — all project information and participating software 
products are located on a single computer, and the FactoryTalk-enabled 
system cannot be shared across a network or accessed remotely. 

 Network Directory — organizes project information from multiple 
software products across multiple computers on a network. 

Some FactoryTalk-enabled products require a Network directory, others 
require only a Local directory, and some require that both directories be 
configured. 

Keeper — Device responsible for distributing link configuration data to all 
nodes on the network. 

Invalid keeper — An invalid keeper is any keeper capable device that has 
joined an existing network but does not share the network signature with the 
current active keeper. An invalid keeper will automatically assume the role 
of the active keeper if there are no other valid keepers on the network. 

Keeper signature — Indicates a unique, hexadecimal value that is stored by 
each keeper-capable device to uniquely identify a specific network 
configuration. During initial start-up, the keeper capable device determines 
if: 

 another keeper-capable device had previously configured the network. 

 its internal signature matches the network signature. 

If the signatures match, the keeper-capable device joins the network as the 
valid keeper. If the signatures do not match, the keeper joins the network as 
an invalid keeper. 
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Macrocycle — A macrocycle is equal to 128 NUIs (Network Update 
Intervals). A macrocycle is the maximum period before scheduled traffic 
repeats. 

Maintenance message — Allows the node with the lowest address to 
transmit information to keep the remaining nodes synchronized. This time is 
automatically subtracted from the network update time (NUT). 

Maximum scheduled node — This is the node with the highest network 
address that can use scheduled time on a ControlNet link. 

Maximum unscheduled node — This is the node with the highest network 
address that can use unscheduled time on a ControlNet link. 

Tip: Nodes set at addresses higher than the maximum unscheduled node do not 
communicate on the network; for example, they will not display in RSLinx Classic. 

Multicast connection — A connection made from one node to many nodes. 
Multi-cast connections allow multiple consumer nodes the ability to receive 
data from a single producer node. 

Multi-Keeper device — A keeper device that supports multi-keeper network 
capabilities. 

Multi-keeper network — Specifies that more than one keeper-capable 
device on the network can store the ControlNet network parameters and the 
ControlNet schedule for all scheduled connections on the network. The 
connections may or may not involve the keeper-capable device itself. 

In a multi-keeper network, at least one valid multi-keeper device must be 
present on the network for any new scheduled connections to be established. 

Tip: In a multi-keeper network, it is not required for the device at node 1 to be a valid 
keeper; RSNetWorx for ControlNet can be used as long as one multi-keeper device 
is present on the network. By default, the keeper-capable device at the lowest 
node number will be the only active keeper. 

Node — A node is a ControlNet address. When a device is added to the 
network, it is assigned a node address from 1 to 99. 

Network update interval — The network update interval (NUI) is one 
interval on the network equal to one NUT. Within each NUI, scheduled data, 
unscheduled data, and network maintenance information is transmitted. 

Network update time — The network update time (NUT) is the repeatable 
base time at which the network can transmit data. This is user-configurable 
(in the range of 2 -100 milliseconds); the default value is 5 milliseconds. 

Each NUT is divided into three major components: scheduled messages, 
unscheduled messages, and maintenance messages. For more information on 
the components of the NUT, see information exchange on a ControlNet 
network within the online help. 
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Peak scheduled bandwidth — Displays the percentage of peak scheduled 
bandwidth determined over the maximum, or worst case, network update 
interval in the configuration. 

Point-to-point connection — A connection made between two nodes only. 

Process control sample complete (PCSC) — Using a few status bits, PCSC 
notifies the PLC-5C processor user when a specific piece of new scheduled 
data arrives. 

Producer — A node that is responsible for transmitting data on a ControlNet 
link. 

Redundancy — Can be used to indicate both of the following: 

 an independent connection type where both a primary and secondary 
device share control of outputs and send configuration data to the 
network. If you have an existing Redundant connection to a target 
device, you can specify another Redundant connection to that same 
target device, but cannot specify an Exclusive Owner connection. This 
connection type is used with a ControlNet PLC-5 Hot Backup system. 

 a dual-cable system setting that allows you to receive the optimum 
signal over a ControlNet network. In a redundant media system, one 
cable system uses Channel A and one cable system uses Channel B. 

Requested packet interval — The requested packet interval (RPI) value is 
determined by how often you want a particular piece of I/O or scheduled 
peer-to-peer data to be transmitted within the scheduled bandwidth of the 
NUI. 

Scanlist Configuration Tool (SCT) — A program that maps processor 
memory onto the network and network data into processor memory. SCTs 
are scanner-specific; therefore, a unique SCT is required for each type of 
scanner. 

Scanner — A ControlNet device that is a connection originator. 

Scanner class device — A device that initiates connections and contains a 
scanlist. Refer to the RSNetWorx for ControlNet online tutorial for more 
information. 

Scanner signature — Indicates a hexadecimal value, unique to the scanner, 
that is assigned to scanner devices that originate scheduled connections; a 
copy of the scanner signature is held by the active keeper. This value is 
stored in the scanner and in the offline configuration, and is used to 
determine if the offline and online configurations are synchronized. When a 
scanner device with scheduled connections joins the network for the first 
time, it requests it's scanner signature from the active keeper. If the scanner 
signature matches the scanner signature obtained from the active keeper, then 
that device is allowed to open its scheduled connections. If the scanner 
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signature does not match, then the device is not allowed to open its scheduled 
connections. 

Scheduled bandwidth — The amount of scheduled (i.e., time-critical) data, 
including I/O data and peer-to-peer interlocking data, that can be transmitted 
within the network update interval (NUI). The percent of scheduled 
bandwidth usage varies depending on the network configuration. 

Tip: It is possible for the amount of scheduled data you wish to transmit to exceed the 
scheduled bandwidth. In other words, the speed at which you are able to transmit 
data is somewhat determined by the limitations of your particular system. You 
should keep this in mind when setting up your network. A good guideline to follow 
when determining your network update time (NUT) is .5 ms per rack. 

Scheduled message — The network allows every scheduled node (on a 
rotating basis, in sequential order) a guaranteed opportunity to transmit 
information. 

Information that is time-critical is sent during the scheduled message 
component of the network update interval (NUI). 

Single-keeper device — Specifies that the keeper-capable device at node 1 
must store the ControlNet network parameters and the ControlNet schedule 
for all scheduled connections on the network. The connections may or may 
not involve the keeper-capable device itself. 

In a single keeper network, a valid single keeper device must be present at 
node 1 for any scheduled connection to be opened. After a scheduled 
connection is established, the network will continue to function even if the 
single keeper device at node 1 is removed from the network. 

Tip: In a single keeper network, the device at node 1 must be present and a valid 
keeper to use RSNetWorx for ControlNet. 

Slot time — The time to wait for a skipped network address or missing node 
from the network. This value is based on the physical attributes of the 
network, such as cable length and number of repeaters. 

Status file — 

PLC-5C processors 

The status file is a user-specified integer data-table file starting at word zero. 
This file stores status information for each individual connection entry in the 
map table. The length of this file will vary depending on the number of 
connection entries; three words are allocated for each connection entry. 

1747 Scanner 

The status file is a module input file for the 1747 SCNR. Status files are most 
appropriately used for non-critical I/O data transfers. There is no image for 
these files in the processor memory. 
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You can access ControlNet data located in status files using the COP(copy) 
instruction in your ladder program. The maximum data length you can 
transfer with the COP instruction is 128 words. The following explains the 
addressing format of Status files: 

Mf:e.s/b 

M=module 

f=file type (1) 

e=slot (1-30) 

s=word (600 to max. supplied by module) 

b=bit (0-14, even #s only) 

The maximum number of words that can be supplied by the 1747-SCNR is 
607. 

Unscheduled bandwidth — The amount of unscheduled (i.e., 
non-critical-time) data, including all programming and operator interface 
data, that can be trasmitted within the network update interval (NUI). 

Unscheduled message — The network allows all nodes (on a rotating basis, 
in sequential order) to transmit information. This rotation repeats until the 
time allotted for this component is complete. 

The amount of time allocated for the unscheduled component is determined 
by the information load of the scheduled component. At least one node will 
have the opportunity to transmit unscheduled messages every interval. 

Information that can be delivered with minimal time constraints is sent 
during this component of the network update interval (NUI). 

Valid keeper — A valid keeper is any keeper capable device that has joined 
an existing network and shares the network signature with the current active 
keeper that established the network. If there is no active keeper when a valid 
keeper capable device joins the network, then its network signature must 
match the network signature that any other device obtained when it joined 
the network. A valid keeper will automatically assume the role of active 
keeper if the current active keeper were to fail. 

When a network consists of valid keepers or both valid and invalid keepers, 
the valid keeper located at the lowest node number on the network becomes 
the active keeper. If there are no valid keepers on the network, a 
keeper-capable device acts as a faulted keeper until a valid keeper becomes 
part of the network. 
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Rockwell Automation support 
Rockwell Automation provides technical information on the web to assist you in using its products. At 
http://www.rockwellautomation.com/support  you can find technical and application notes, sample code, and links to software service 
packs. You can also visit our Support Center at https://rockwellautomation.custhelp.com  for software updates, support chats and forums, 
technical information, FAQs, and to sign up for product notification updates. 

In addition, we offer multiple support programs for installation, configuration, and troubleshooting. For more information, contact your 
local distributor or Rockwell Automation representative, or visit http://www.rockwellautomation.com/services/online-phone . 

Installation assistance 

If you experience a problem within the first 24 hours of installation, review the information that is contained in this manual. You can 
contact Customer Support for initial help in getting your product up and running. 

United States or Canada 1.440.646.3434 

Outside United States or Canada Use the Worldwide Locator available at http://www.rockwellautomation.com/locations , or contact your local Rockwell 
Automation representative. 

 

New product satisfaction return 

Rockwell Automation tests all of its products to ensure that they are fully operational when shipped from the manufacturing facility. 
However, if your product is not functioning and needs to be returned, follow these procedures. 

United States Contact your distributor. You must provide a Customer Support case number (call the phone number above to obtain one) to 
your distributor to complete the return process. 

Outside United States Please contact your local Rockwell Automation representative for the return procedure. 

 

Documentation feedback 

Your comments will help us serve your documentation needs better. If you have any suggestions on how to improve this document, 
complete the feedback form, publication RA-DU002 

 

http://www.rockwellautomation.com/support
https://rockwellautomation.custhelp.com/
http://www.rockwellautomation.com/services/online-phone
http://www.rockwellautomation.com/locations
http://literature.rockwellautomation.com/idc/groups/literature/documents/du/ra-du002_-en-e.pdf
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